Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I'm in a directory that contains a file called "日本語.txt", dir will show the filename as "???.txt". I tried changing the command prompt font to Lucida Console, but then the name just shows up as a bunch of boxes. I know Lucida Console has Japanese characters, so why doesn't it work?

share|improve this question
3  
See also stackoverflow.com/questions/1259084/… – Sinan Ünür Feb 2 '10 at 2:40

That's a problem related to the CODE-PAGE used (think about it as a linux LOCALE). You set those up with the chcp command

CHCP [nnn]

nnn Specifies a code page number.

Type CHCP without a parameter to display the active code page number.

Try by setting one of the CPs commented here: http://en.wikipedia.org/wiki/Code_page

By the other side, if you use the Lucida Font in console, you can allways copy the garbled output and paste it in a word processor. The characters will be readable there.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .