Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am facing some problems with my Windows XP installation. All of my applications (Firefox, Winamp, antivirus, sometimes Windows Explorer) are crashing. Sometimes I get a BSOD:

enter image description here

What could be the problem? This has been happening since I removed my CD-ROM.

Has my hard drive developed some bad sectors, or perhaps there is a problem with the RAM? Do I need to low level format my hard drive to mark bad sectors?

share|improve this question
1  
Maybe you need to install more than one Window. Most of us have Windows. ;-) –  Chris W. Rea Feb 2 '10 at 14:19
add comment

migrated from stackoverflow.com Feb 2 '10 at 9:25

This question came from our site for professional and enthusiast programmers.

4 Answers

Download the appropriate hard drive manufacturer utility listed here to check your hard drive for bad sectors without having to do a low level format.

Run memtest86+ to test your memory.

When you removed your CD-ROM, you may have unseated an add-in board or memory module. With power disconnected, and observing anti-static precautions, remove and reseat all components and cables.

If your system complains about a missing device on startup, and the CD Drive you removed was SATA, go into the BIOS and turn off that SATA port. (I know for a fact this applies to some Dells; not every manufacturer has this issue).

share|improve this answer
add comment

This might sound silly, but try re-adding your CD-ROM drive and seeing if the problem still manifests. If so, there could be something in your Windows installation which (erroneously) relies on the hardware not changing.

Otherwise, my suggestions are:

  • Update drivers, or roll-back ones you have recently installed (I've had some bad experiences with upgrading nVidia's drivers from time to time)
  • Re-seat anything with a plug: power cables, RAM sockets, drive connectors etc, especially those around the drive bay
  • Hardware diagnostic utilities such as memtest86+ (the link posted earlier is to a parked domain, but you can find it on any Linux LiveCD image)
share|improve this answer
add comment

With this Bluescreen, the first thing I would do is as Ngu Soon Hui said and check that all RAM is seated correctly.

After this, try running a full memory check using memtest86+.

If this finds nothing, try looking for and downloading the latest drivers for your motherboard and other devices as this can help.

On the other hand, it can also be caused by having too many drivers that conflict with each other - you may want to go through your system and generally uninstall old programs / device drivers for devices you no longer use... And check what applications were installed recently.

share|improve this answer
add comment

Since you mention that this happened after you remove the CDROM, it is likely that you accidentally turn other components in the motherboard ( such as RAM) on loose.

Make sure that RAM etc all are fully connected to the motherboard.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.