Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Debian 5.0 (Lenny)...I can't find where SHELLOPTS is being set by default. I've checked:

  • ~/.bashrc
  • ~/.profile
  • ~/.bash_profile (doesn't exist)
  • /etc/bash.bashrc
  • /etc/profile

... nowhere to be found. The issue is I want to change emacs to vim in editor style field. Anyone know where I can find/set this?

share|improve this question
1  
Have you tried 'export EDITOR=vim' in .bashrc? –  MrStatic Feb 2 '10 at 15:00
    
Yep, and that also works, thanks! –  AJ. Feb 2 '10 at 15:46
add comment

1 Answer

up vote 1 down vote accepted

It has some default settings. Just add:

set -o vi

to your ~/.bashrc file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.