Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Periodically, the internet simply stops working in my virtual machine, and the only way I can get it working again is to restart the host computer. Since I use the virtual machine specifically for testing web pages, this is, shall we say, a bother.

Details: I have Windows XP Pro running in VMware Player (v. 3.0.0 build-203739) on a Windows 7 host. It's set to NAT (shared IP address) because the firewall won't allow a bridged connection.

Every couple of days or so, first the internet slows down to a crawl, then eventually it stops working altogether. Both VMWare and the virtual OS report that they are connected, everything looks just peachy, I can reach the internet from the host, but on the VM, all web pages time out and/or report that the server could not be found. (Browser-independent; tried with IE, FF, Chrome, Safari, and Opera.)

When this happens, the only way I've found to restore the internet connectivity is to restart the host machine. Restarting the VM doesn't help, nor does refreshing network connections on either the host or the guest. (Although I'm not entirely sure I've found the proper way to refresh a network connection in Windows 7...)

I have not noticed any predictability about when the problem occurs, i.e. it's not immediately after I do anything special. It seems to occur mostly after putting the host to sleep once or twice, but it has happened even if the host has been in continuous use. It also seems independent of when I start using the VM - sometimes, I wake up the VM and the internet is really slow in it, then eventually stops working altogether; other times, I wake up the VM, use it perfectly happily for a while, then suddenly the internet is gone.

Does anyone know why this is occurring? Failing that, is there a workaround that's less drastic than restarting the host? (Windows 7 startup times are blazingly fast compared to previous versions of Windows, but it's still a hassle to close all my programs and reopen them again.)

Edit: while badges overall are nice, the Tumbleweed badge isn't helping me to solve my problem. Hasn't anyone encountered anything even remotely similar?

share|improve this question
    
I've had similar problem but I use bridge option instead of the NAT. What I did, I made sure that both VMPlayer's NICs in the host - Win 7 - have their IPs assigned dynamically and have the guest with static IP. For example, if your router is 192.168.1.1 then I would assign 192.168.1.10 to the host and then 192.168.1.20 to the guest provided those IPs don't conflict with your DHCP pool. –  Darius Oct 4 '12 at 16:03
    
Just a note that I'm no longer experiencing this problem, because that particular computer gave up the ghost a while back. I'm now on a Windows 8 (hack, ptui) box and the internet seems to stay up just fine on all my virtual machines. If anyone else is having this issue and one of these answers was helpful, could you add a comment to that effect? I'd like to un-accept my placeholder answer and accept a real answer, but have no way of testing things. –  Martha May 3 '13 at 16:10

7 Answers 7

This happens to me too. I did the following:

  1. I find the network adapter on the host which VMware Player is using (in Network Connections). In my case, it is named VMware Network Adapter VMnet8.

  2. Right-click on it then select Disable. I then wait for the Guest OS to report 'cable unplugged' from its taskbar (my guest is WinXP).

  3. Back in the host, right-click on the same adapter the select Enable. Wait for the guest taskbar no-connection icon to switch to the getting-an-ip-address animation, then after the IP address is allocated, test the connection.

My web access is restored with this method.

share|improve this answer

In my experience, if my host OS goes to sleep while the VM is running, I lose network connectivity from the guest OS, and the only way to resolve the situation is to reboot the host OS. However, I found that if I suspend the guest OS before the host goes to sleep, the problem never appears.

share|improve this answer
up vote 1 down vote accepted

The resounding silence is impressive...

The workaround I've found is to set the connection mode to bridged, wait for it to realize it can't connect that way, then set the connection mode back to NAT. Not terribly satisfying, but better than restarting the entire computer.

share|improve this answer
1  
If you think it might help, you might consider adding a bounty to your question. –  heavyd Mar 15 '10 at 15:30
    
Have you tried ipconfig/release and ipconfig/renew ? Or even that times out on you? –  Darius Oct 4 '12 at 16:05

I have the same problem, very annoying. Finally I found the solution is:

Player -> Manage -> Virtual Machine Settings ... -> Network Adapter (Bridged Automatic) -> Network connection -> Configure Adapters -> Select the host network adapter(s) you want to antomatically bridge:

Choose the one you have the physical network card and uncheck the VirtualBox Host-Only Ethernet Adapter.

Hope this will help.

share|improve this answer
    
In my case I was using a bridged connection on Win7. Whenever I changed the USB dongle on my router, or unplugged my LAN cord, I lost all connectivity to my virtual machines on Workstation 10. I followed this answer and removed all adapters except one. Rebooted the virtual machines and they worked! Thanks :) –  moomoochoo Jul 22 at 11:28
    
Slight modification. Go to VMware Workstation -> Edit -> Virtual Network Editor-> Network Adapter (Bridged Automatic) ->Click Automatic Settings then remove the network adaptors you don't need. –  moomoochoo Jul 22 at 11:55

On vmware player right clic> disconnect the network using the icon at the bottom of the window.

Go in the windows network connections, disable all connections except the one you want VMware player to use. Reconnect vmware player. Now it should work.

share|improve this answer
  • Go to Virtual Machine Settings.
  • Click on Network Adapter.
  • Click Remove.
  • Click Add new network adapter.

Should solve the problem.

share|improve this answer

I have the same network connectivity problem upon first startup of the vmimage (i.e. the network appearing OK on both host and vmware image). I close down the vmware image, close down vmware, restart the router, restart vmware, restart the image, and it's back on the network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.