Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How to disable autorun for XP Home

I'm sure this has been answered before but I'm going to ask again because I couldn't seem to find the answer. A machine has been hit by that nasty little yt8a.exe that autoruns on boot and installs itself on other machines by using the autorun from a USB Key (Thumb Drive). How do I disable it?

Here is what I've tried:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001
"NoDriveTypeAutoRun"=dword:000000ff

Then on my thumb drive I setup the following Autorun.inf

[Autorun]
label=ARTest

So my logic is if autorun is in fact disabled the drive should show a generic message but it keeps showing the label ARTest so I'm assuming autorun is not turned off. Can someone please clarify. Note: I did reboot and I also installed MS's KB 953252.

share|improve this question

migrated from stackoverflow.com Feb 2 '10 at 18:58

This question came from our site for professional and enthusiast programmers.

marked as duplicate by random, Diago Feb 5 '10 at 15:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

Go to Start Menu -> Run and type gpedit.msc

There go to Computer Configuration -> Administrative Templates -> System

On the right panle, double click on Turn Off Autoplay.

On the new window, select Enabled, and on the drop down list, select All Drives. Click OK to everything and restart your computer and autorun should be disabled for good.

share|improve this answer
    
Note: You may need to add the system template using menu Action | Add/Remove Templates while the Administrative Templates item is selected. –  Lawrence Dol Feb 2 '10 at 19:31

I should have mentioned the not all of the machines I have access to have the ability to do go to "gpedit.msc > Computer Configuration -> Administrative Templates -> System" which is why I was looking at the registry option.

share|improve this answer