Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On two different FTP accounts, I am having problems uploading files. I can login and see the contents of the dir, and start an upload. Using Filezilla the transfer seems to always stall at either 0.9% or 1.2% (always those two numbers) and may simply hang, or keep restarting and then again stop at the same point. WindowsXP FTP is not great but I get similar types of problems there... it starts uploading and after a short while I get a timeout error.

FTP used to work fine, and I don't know if it's these accounts in particular (both have the same service provider although purchased on opposite sides of the world) or if "FTP is broken on my PC"... can that even happen?!

share|improve this question

migrated from serverfault.com Feb 2 '10 at 19:30

This question came from our site for professional system and network administrators.

4 Answers 4

This issue could be related to a number of things:

  • The provider - as both these accounts are with the same provider, there could be an issue with them, or the settings you are using to connect to them, can you try ftp'ing to a completely different account?
  • Your internet connection - maybe your ISP is having issues, or throttles FTP for some reason, can you get someone else at a different location to try ftp'ing to that site to see if it works.
  • Your software - maybe your software is not configured correctly, or maybe your firewall is causing an issue.

The key to solving this problem is eliminating what is not causing the problem, once you know what’s definitely not the cause, you can home in on the actual problem.

share|improve this answer

Try using passive FTP as opposed to active and see if that clears up your issues.

share|improve this answer

It's a bit of a long shot but see what happens if you disable your antivirus software for the duration of the transfer. It's possible the AV software is holding up access to the file on your end, causing a timeout while reading it.

share|improve this answer

Try enabling the logging and debugging options in Filezilla. Enable timestamps. Max out the debug options. Follow the steps you take to reproduce the problem, then disconnect, close Filezilla and check the log. That might give you some clues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.