Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

There are a few sites I have visited by mistake. These are not bookmarked, but despite repeated clearing of browser history, both from within Firefox, and using CCleaner, Firefox keeps suggesting these sites via autocomplete in the location bar. This happens on both OSX and Windows.

For example, one time, about 23 versions ago, I typed vim and then accidentally pressed ⌘-Enter instead of ⌘-Shift-Enter. The latter would have browsed to www.vim.org whereas I ended up on www.vim.com.

To this day, when I type vim in the location bar, I am offered vim.com, and not vim.org as the first choice even though I have cleared history many times, and vim.org is bookmarked:

Firefox autocompletes vim to vim.com

How can I get Firefox to offer vim.org (which is bookmarked) instead of vim.com (which is not bookmarked) when I type vim in the location bar?

PS: Search suggestions in both the search bar and the location bar are disabled.

PPS: On my MacBook Pro, if I press Delete, or ⌘-Delete, or Shift-Delete, it clears vim.com from the location bar, but the same thing happens again the next time I type vim into the location bar.

PPPS: The magic of asking on SuperUser strikes. Doing the same thing I have done before, delete from auto-complete, clear history, and then clean using CCleaner, I now have what I want.

share|improve this question

marked as duplicate by DavidPostill, Community Feb 14 at 1:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The marked "duplicate" Q is about text entered into a form field in a web page, it doesn't even mention the location bar / address bar. Just because they share the same basic answer doesn't really make them duplicates. – Xen2050 Feb 14 at 4:25
1  
It sounds like you solved it, but here is a similar question: superuser.com/questions/1014611/… Maybe the answer will be useful to someone – MC10 Feb 22 at 17:08
up vote 24 down vote accepted

As you're typing the v i ... in the location bar and the autocomplete menu pops up underneath, use the arrow keys to select/highlight the unwanted entry, then press the DEL key to remove it from the list.

share|improve this answer
12  
The length of a reply does not have an impact on whether should be a comment or an answer. what does have an impact is whether it solves the problem. – Nzall Feb 13 at 15:34
    
Wow, I can't believe I never thought of this either after years of being a firefox user. Totally worth an upvote! – Adam D. Ruppe Feb 13 at 15:36
    
@NateKerkhofs True, but my first idea of "press del" would have been too short even for a comment ;-) – Xen2050 Feb 13 at 16:47
    
I have to use shift del – user1717828 Feb 13 at 19:27
2  
@DougKavendek & Sinan Ünür Firefox can sometimes get it's profile "frozen" or otherwise corrupted so it's always in the same state, new bookmarks or history doesn't stay after a restart, and old stuff can't be deleted (or much worse symptoms). Search the web for something similar to "firefox fix corrupted profile" for some info on how to save some data (generally involves creating a new working profile & copying over some data) and see Mozilla's support site support.mozilla.org specifically Firefox won't save settings or remember information – Xen2050 Feb 14 at 11:59

It should simply be a case of hovering your mouse over the item you want removed and hitting the DEL key (Note on Mac, you may need to use SHIFT + DEL or with an extended keyboard SHIFT + BACKSPACE.)

More information here.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.