Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to install Office 2007 on my new Win 7 box, but after inserting the DVD (original Microsoft disk), the drive kept trying to read the disk and nothing happened at all. I couldn't browse it nor start manually. After removing the disk I got the error message that the format operation failed . The disk seems fine, because I was able to mount it correctly under Linux on the same machine. Any ideas? I thought Win 7 was supposed to be better than XP an Linux?

share|improve this question
Can you read other DVDs on this system? – ChrisF Feb 3 '10 at 11:16
@ChrisF, I only tried video DVD's, which worked fine. I will try some data DVD (in the evening when I have access to the box) – Grzenio Feb 3 '10 at 11:22
I've installed Office 2007 onto Win7 Enterprise machines from DVD and from the network with no problems recently. It could be a bad/dirty DVD that's damaged on the section that's auto-running rather than the part that holds the directory listings? – GAThrawn Feb 3 '10 at 14:04
@ChrisF, I checked and even the second office disk opens fine on this machine. – Grzenio Feb 4 '10 at 11:45
That would indicate that you've got a faulty disk. If other disks open OK on this machine then it's not likely to be the drive. Have you tried this disk in another machine? – ChrisF Feb 4 '10 at 12:26

Just because you are able to mount the disc in Linux doesn't mean that the disc isn't too damaged to install properly in Windows.

Sounds to me like the disc is damaged or your DVD drive/drivers are bad. Try initializing the installation process on another (Windows) computer. If it allows you to initialize the installation, then it is the drive or that machine. If not, then the disc is bad.

Once you know if it is your computer or the disc, you can go from there.

share|improve this answer
The disc must be fine, it was brand new in sealed package before I used it for the first time. And I think that I should be able to list the contents of the disk if I can do it in Linux. The hardware is good enough to do that. – Grzenio Feb 3 '10 at 15:36
You cannot assume that the disc 'must be fine because it is brand new'. We recently received a few copies of Office 2007 and the packaging easily causes the discs to become dislodged causing major damage and scratches. – th3dude Feb 3 '10 at 16:08

You're probably dealing with a bad combination of drive and disk. Windows 7 and Office 2007 work fine together. If you have a second machine you can try these options to try and get the software installed:

  • if the second machine has a dvd drive, you can share that drive and access the installation files over a network.
  • Or you can convert the disk into a ISO and mount it virtually instead of physically by copying it to the problem machine or from a networked machine.
  • Or you can try a second physical DVD drive in the problem machine and see if that works.
  • Last you can make a copy of the installation DVD onto a new DVD and see if that would work in the problem machine's DVD drive.

Hope this gives you some options to work with.

share|improve this answer

Same for me as GAThrawn. You also can try to install Office 2010 Beta that is now available and I use it, so far so good!

About Office 2007, it shouldn't be any issue installing this software except if that DVD is broken, scratched or files corrupted.

Do you have an error message?

P.S. Why can't I just reply a comment?! Only answer...

share|improve this answer
Hi, I don't have any error messages - it just hangs trying to start (I waited about 45 minutes and nothing happened). – Grzenio Feb 3 '10 at 15:36
@r0ca - you need 50 rep to be able to leave comments - – ChrisF Feb 3 '10 at 15:57
Try this then: -… ;) – r0ca Feb 3 '10 at 16:31
up vote 0 down vote accepted

Finally I just copied all the files from the original DVD to a USB stick in Linux, rebooted to Windows and installed it successfully from the usb stick. So both the drive and the disk were fine and worked fine together.

share|improve this answer

Right click on the setup.exe or autorun.exe files and click on "run as administrator"

should work Had similar issue

share|improve this answer
I couldn't even browse the disc :( – Grzenio Feb 8 '10 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .