Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm away from my office mac I typically login via screen-sharing or VNC from home/another mac. Lately, after using screen sharing this way, my office mac will have several problems:

  • Command+tab and Command+` no longer work
  • Expose and other F-key functions no longer work
  • ctrl+space to launch Google QSB no longer works

Things I have tried to remedy this:

  • Restarting the Finder process
  • Restarting the Dock process
  • Disabling the screensaver
    • Unfortunately, the screensaver still runs... A connected issue?
  • Deleting preference files for Dock/Finder/screensaver etc.

The only thing that seems to work is a restart. I usually try and avoid that.

System details:

  • Macbook pro 13"
  • OS v10.5.8
share|improve this question
    
Does killing the screensaver daemon or setting to a different screensaver not help? –  ayaz Feb 3 '10 at 18:25
    
I didn't try setting another screensaver. I just changed the time to start to 'Never'. But killing the screensaver daemon does nothing. –  moshen Feb 3 '10 at 18:27
    
It seems like the new version of Chromium is causing the problem. –  moshen Feb 8 '10 at 20:40
    
Scratch that... Just had it recur. –  moshen Feb 10 '10 at 20:42
    
Im stuck with this problem too. Looks like there is no solution –  Zubair Mar 28 '10 at 16:08

2 Answers 2

I've been trying to figure this out for some time. I think I found something that works. It worked for me just now without having to reboot.

First, go into your ScreenSharing application preferences and write down your settings (there are only a handful). Then quit ScreenSharing.

Next, go into your user directory in the Finder, then navigate to Library -> Preferences. It's important that you do this through your user folder and not through the Library folder that's on the root of your hard drive.

Once in your Preferences folder, delete com.apple.ScreenSharing.plist and com.apple.ScreenSharing.plist.lockfile (or you can add an arbitrary extension like .old to them if you want to play it safe and be able to re-use the old preferences files.

Finally, restart ScreenSharing. Re-enter any adjusted preferences for that application if you had any that you wrote down. Your F-keys, Cmd+Tab, Cmd+Space, and other keyboard shortcuts should once again be working.

Hopefully this will fix it for good. I suspect my preferences file was corrupted, and deleting it caused ScreenSharing to create a fresh one. Either way, it's an easier fix than having to reboot, so give it a shot.

share|improve this answer
up vote 0 down vote accepted

This seems to have been resolved after upgrading to 10.6.* (not a reinstall, just upgrade)

No indication of what caused it originally.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.