Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is not just a problem with Windows 7 - I know I've been experiencing this same issue all the way back through XP. Basically, you set your screen to turn off after 5 or 10 minutes, you walk away, the screen turns off after 5 or 10 minutes. Then 2 or 3 days later, for some reason, the screen stays on at all times despite this setting.

I went back and checked my power settings and they still say the screen should go off after 5 minutes, but that is not what's happening. After I set it to 5 minutes again (even though that's what it already says), and click OK, then the feature works...well for a few days anyway until we go back to step 1.

Anyone having this issue constantly?

share|improve this question
add comment

3 Answers

up vote 9 down vote accepted

Could be a lot of possible reasons, here are my guesses:

  1. It could depend on your mouse, I've had mice that even while completely still on a table send a very minor cursor movement signal back to the PC. Try unplugging the mouse to see if that's the cause.

  2. There are applications that actively prevent windows from turning the screen off, full screen video is the obvious one, there may be something else you have running, check your background applications.

share|improve this answer
    
Ok, my screens now turn off if I unplug my Microsoft Wireless Laser keyboard 6000 v2.0 , now I can't type ;-) (I don't use the mouse that comes with it, I took the batteries out, I use a wired mouse instead) do you have any suggestions about how I could use this keyboard AND power saving? I have installed the drivers from microsoft.com/hardware/en-us/d/wireless-laser-keyboard-6000v2.0 and disabled the mouse in device manager, and unticked allow this device to wake the computer... still no luck. –  Myster Aug 4 '11 at 2:42
    
ok, I put the batteries back in the mouse, connected it, took the batteries back out again and it's all working now. –  Myster Aug 4 '11 at 2:53
add comment

I found this site to be very useful in solving this problem for me, using Windows 8.1:

Windows 7 Screensaver and Power Options Not Working?

The solution for me was Method 4 – Disable Wake Features.

I was able to quickly use the command prompt, with the command

powercfg /devicequery wake_armed

to discover that my network adapter was set to wake up the computer all the time. I changed that setting and my problem was solved. I tested it by setting my display to turn off in one minute, sat back for a minute, and presto! it turned off nicely.

share|improve this answer
add comment

I hear your pain. Here's a little story you can hopefully gleen some usable info from. ;)

I dealt with similar for over a year, and it cheesed me off occasionally although I usually turned my monitors off anyway (CRTs). What was really annoying is that sometimes it would occasionally work on it's own for a while and then stop working again for weeks or longer, no rhyme nor reason. ;) No screen savers either - If I "previewed" the screen saver it worked as expected, no problem, mouse/KB stopped it as expected as well.

Disabling startup utilities via MSConfig didn't help any.

Often it's caused by USB devices that are "Wake Armed", which is a device that can wake up the system. You can get your list in Vista/7 via "c:>powercfg -devicequery wake_armed", usually your mouse, KB and (probably) wired NICs show up.

After sifting though a TON of search results that didn't quite match my problem, it seemed that most peoples' answer was their KB and/or mouse keeping the system awake.

I tried pulling my USB mouse and KB, as well as disabling the NIC in the BIOS. It still wouldn't sleep.

I searched for (new) answers on and off over the months.

I became convinced it wasn't the OS because it lasted through an upgrade to Win7 from Vista.

And soon after doing that I got myself some brand-spankin' new LCDs and was suddenly more determined to figure it out.

I broke down and unplugged all other USB devices (other than KB and mouse), of which I have several (various controllers, camera, mp3 player, etc.). Low and behold it worked with nothing BUT the KB and mouse plugged in. So I spent the time to plug them back in, one at a time, and wait for the screen saver/power saving timer to lapse for each new addition.

It turns out (in my case) it was my PC/XBox Xplorer guitar controller from Guitar Hero 3 PC! it "only" took me 5 devices to find it. :/ I searched for that problem specifically, and found new results of a couple other users who had the same problem with the Xplorer for the PC.

The annoying thing is it was always plugged in, even when it WOULD sleep. But it turns out that if the guitar connection itself got out of whack some how (randomly gets the full ring XBox green ring instead of just 1/4 of it when it's been sitting for a few days) then the sleep would magically start working.

Adding to this was that one of the few things my G/F was doing on the PC during this era, when I was at work, was playing GH3. If the guitar was out of whack, she'd just hit the big XBox button on the guitar and correct it to play.

And then at some point later I'd notice that the power saving had magically stopped working again.

So now I unplug the guitar when I'm not using it. Ironically, my PS3 Wireless guitar that I also plug into USB doesn't cause this problem, even though it's not even supposed to be Windows compatible!

Long answer, hope it helps (if you're still even reading this)! ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.