Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

If I try to copy a file onto a NTFS partition in Linux, I get a warning message Could not change permissions for <file-name>. Is there any way to suppress this message ? I can live with this message while I copy the files in terminal, but when transferring from Dolphin a modal dialog box is shown and it gets pretty irritating.

I'm using openSUSE 11.2, on KDE 4.4 RC.

share|improve this question

3 Answers 3

Try using the silent option in the /etc/fstab for the partition you are trying to copy to.

For more information on how to use silent have a look at http://man.linux-ntfs.org/ntfsmount.8.html

share|improve this answer
    
Thanks, I'll have a look and get back. –  Sathya Feb 10 '10 at 15:02
    
Manish, I had a look at the man pages, it says silent option is enabled by default. I explicitly passed the silent option, and still the message pops up. –  Sathya Feb 23 '10 at 1:06
    
I can confirm that after replacing default_permissions for silent in /etc/fstab solved the problem for me. –  dimitko Aug 4 '12 at 11:29

edit fstab and change this portion of the windows line:

user,users,gid=users,fmask=113,dmask=002,umask=002,locale=en_US.UTF-8

to this

defaults,locale=en_US.UTF-8

http://forums.opensuse.org/applications/434289-permission-error-when-writing-ntfs-dolphin.html

share|improve this answer

Change the line:

/dev/sda6      /mnt/sda6       ntfs-3g defaults,silent,locale=en_US.utf8,auto,rw,allow_other,umask=000,gid=users,user,nls=utf8,exe 1     0

to

/dev/sda6       /mnt/sda6       ntfs-3g         defaults,locale=en_US.utf8      1       0*

No more dolphin messages! Vector Linux 6.0 SoHo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.