Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
I have a Compaq Presario CQ61, instaled Ubuntu 9.10 and Windows 7 on it. 

It works great except the PPPoE connection in Ubuntu, when i dial in Windows my download speed reach up to 91 Mb, rebooted in Ubuntu, downloaded same file from the same server with a speed of maximum 3 Mb, cheked in Windows again 80 - 90 Mb constant. I can't figure what slow's the internet connection in Ubuntu.

Anyone has an ideea on this problem ?

(NO iptables configured, NO HTB, CBQ ...etc configured) .

Thank you

EDIT: I don't have any modem or router. I am using PPPoE directly from my PC.
I didn't mentioned that I instaled Ubuntu two times but didn't figured out what was causing the problem, so I instaled Fedora 12 (64), this works fine and the speed reached 85 Mb.
I instaled latest Ubuntu 10.4 on the same Laptop, the problem is not solved, the speed reaches up to 3Mb, when in Windows or Fedora reaches up to 95 Mb (yesterday).

Anyone has any ideas on what should I do ? Thank you.

share|improve this question

migrated from Feb 4 '10 at 14:16

This question came from our site for professional and enthusiast programmers.

Just out of curiosity, what type of broadband are you using? Cable? Satelite? Fiber? Any reason why you aren't letting your modem/router handle the PPPoE handshake?

share|improve this answer
This should be a comment, imho. – Bobby Jul 26 '10 at 7:23
upgraded the question with an answer to your question. :) – Radu Maris Aug 6 '10 at 15:50
up vote 0 down vote accepted

Problem solved :)

I changed the driver of my ethernet from r8169 to r8101 ( download from here ).

Now I downloaded the same file from the same server with 76 Mb ( maybe the server is a little overloaded now :) , but the difference from 3 to 76 is huge ).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .