Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using OO 3.1.1 on Ubuntu 9.10 (in case that matters to the answer).

I like my dates to appear as YYYY-MM-DD. I can't think of a time when I want to see a date in any other format, so I'm constantly changing how dates look. That's manageable, though annoying. What's gotten me to the point of posting is that when I edit a cell with a date value, I have to edit it in the format MM/DD/YYYY, which is really, really annoying, as I'm usually mucking with the day (or possibly the month), and very seldom the year. So there's lots of cursor or mouse use, wasting my time.

So is there a way that I can change how dates are edited, or at least the default display format? Thanks!

share|improve this question

3 Answers 3

The closest I could find was creating a style that does what you want. It seems to fix your problem and is easy enough to apply to columns, rows, or blocks of cells. The only thing I didn't take time to figure out was how to get that style into the default template. Though it only takes about 15 seconds and would be better than being frustrated if it ends up being the only answer.

  1. Format > Styles and Formatting
  2. Click in the blank area
  3. Select New
  4. In the General tab pick a name and format to link it to.
  5. In Numbers tab pick the date format you want.
  6. Then just use that style like normal.
share|improve this answer

From the thread of Date format and Regional Settings :

I solved this by opening INSERT, FIELDS, OTHER, or Ctrl+F2 DATES, under formats find ADDITIONAL FORMATS..., in this dialog box you can make your own custom date at the bottom.This is where you input the codes. I made several different formats that I like to use in my word docs.

I don't have OO installed, and so can't test this myself.

share|improve this answer
    
I read through the whole thread and it doesn't really address my problem.....but thanks! –  Joe Casadonte Mar 9 '10 at 2:40

I finally figured out how to do this and am going through and posting the solution to the threads I've been reading for help:

1) in spreadsheet press Ctrl F11 2) Default - Modify 3) Date 4) change the language until you find one that defaults to the format you like (you CANNOT specify your own format) I like Uyghur and Zulu 5) click OK - OK 6) File - Templates - Save 7) File - Templates - Organize 8) right click the saved template and "Set As Default Template"

When a date is entered, it will now be recognized from the correct format and will be rendered in the correct format.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.