Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I got to http://apple.com, the page loads fine and perfectly. But when I click on a link (or type it in) to go another part of the website, it refuses to load. Safari 4 tells me it is 'contacting apple.com', but it never actually starts loading the webpage. When I try Firefox it gets stuck on 'watiing for apple.com'.

Every other website (apart from adobe.com) works fine.

It is a massive pain and I would love to get to fixed soon. What methods should I take to try and fix it?

share|improve this question
2  
The only reason it's displaying Apple.com is that it's cached on your system. So it's most likely a problem with your internet connection. –  Sasha Chedygov Jul 22 '09 at 0:54
add comment

2 Answers

up vote 2 down vote accepted

As you can post to superuser.com, I am assuming that your network is generally OK. I had a similar problem with not being able to access only adobe.com and it turned out to be some really strange issue with the Dlink routers that I was using at home and in the office. I would try the following:

  1. check with another browser

  2. flush your dnscache with dscacheutil -flushcache

  3. Check that DNS lookup is ok, maybe use the open dns servers just incase there is a problem with the DNS records that your router or ISP has.
  4. Reboot your router / ADSL modem

If it still doesn't work, call your ISP and get them to check if there is a problem at there end.

To fix my adobe.com problem, I did all that, then borrowed someone's ADSL modem and swapped it out. Volia the problem went away. In the end I had to buy two new routers, as one couldn't be upgraded to solve the problem, the other did but died a month later.

Hope this helps.

share|improve this answer
    
I had previously had a long series of phone calls with my ISP about this issue, and they had no idea what was wrong. After seeing that you had the same issue with Adobe.com and the Dlink router (same as mine), it gave me more confidence that the problem lies on my end. Now, just a few days ago I bought a brand new Belkin Modem/WiFi router and every website works flawlessly. –  David Pearce Sep 28 '09 at 7:34
add comment

You are behind a firewall, you should configure the proxy preferences with:

cmd+,

I assume you're posting from other computer.

This question is odd in first place... :-/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.