Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Moderator edit: if you have a similar problem, please ask your own question, since it seems there are several things that can cause this situation, it is better to treat each case separately.


Hey guys. I have Windows 7 running on my computer and everything is perfect. There's only one little problem. Sometimes when I leave my computer, I come back and my monitor is turned off or asleep, whichever it is. This is fine, I set it to do this. However, after turning on the monitor and moving the mouse around, the mouse cursor freezes; both the keyboard and mouse don't respond to anything, for example the keyboard's windows key won't bring up the start menu and moving the mouse around does not move the cursor around on the screen. I have to wait about a minute or two before things start working again.

I figured this was a power savings setting problem, so I went into Control Panel > Power Options.

I only have Turn off Display => 30 minutes and Put Computer to Sleep => Never. Of course, I went into the advanced power settings to look through there. I put Never to turn off the hard disk, Sleep after never, and that's about it. Nothing else there looks like it might be causing this. I went into the device manager and checked the mouse and the keyboard, and they both have the Allow this device to wake the computer checked for both of them.

Perhaps this other bit of information might help: Sometimes I VNC into my PC using my MacBook, and sometimes, as soon as it shows me the desktop, the same thing happens. The mouse won't move and VNC won't register any events on the server (Which is my PC of course). I close the client (And I know it has nothing to do with the client), then immediately restart it and try to connect. When I click the connect button, it hangs there, as if the PC is not responding.

Basically it's like whenever I try to wake the computer from sleep, it does so by showing me the desktop, then it freaks out.

Then again, I guess the computer isn't sleeping because the setting is set to 'Sleep after => Never'. I honestly don't know what's going on, would appreciate any insight. Thanks!

share|improve this question
5  
I have a similar problem too... –  RCIX Jul 22 '09 at 2:10
1  
I have this issue as well...hope it is a little better in the final version. Good question. –  NighTerrorX Jul 22 '09 at 17:19
3  
Lol, this seems a common problem then! –  Ivo Flipse Jul 22 '09 at 19:13
    
I understand that you log into your Windows box from a Mac sometimes, but why is this question tagged "Mac"? –  mmc Jul 22 '09 at 21:57
    
@mmc, I think someone was hinting at a re-investement in hardware, although I could be mistaken. –  Avery Payne Jan 29 '10 at 17:55

8 Answers 8

I think the hard drives don't support Windows 7's new Power Management settings.

I'm getting regular Blue Screens of Happiness whenever I try to "wake up" my E-Sata external hard drive. I installed the newest Intel Raid drivers (which I hope contain some updated drivers) and it's better now, but still not perfect.

The default Power Management options in Windows 7 Beta turns off the Hard Disk after 20mins. This could cause problems when the PC comes out of sleep mode or hibernation. To work around the problem set the Power Options for the Hrd Disk to never turn off. To do this

  1. Click Start – Control Panel – System and Security – Power Options
  2. Click “Change Plan Settings” on the “Balanced (recomended)”
  3. Click “Change Advanced power settings”
  4. Under the “Turn Off Hard Disk after” option change the timing to “0″ which should set it to Never. Click Apply and OK.

alt text

share|improve this answer
    
Sorry that I did not mention this in the original question text. I already have this setting set to Never. The reason I didn't originally include it in the Question text was because I thought this was the default setting. But yeah, I've had that setting set to Never. Thanks though I appreciate the response. –  Jorge Israel Peña Jul 22 '09 at 18:45
    
Not a problem, Ill just look and see if I can find something else. Though are you sure this is the power setting you're actually using? –  Ivo Flipse Jul 22 '09 at 19:17
    
Yep, I double checked. –  Jorge Israel Peña Jul 22 '09 at 20:28
    
Try support.microsoft.com/kb/977178 –  Hello71 Aug 15 '10 at 15:30

Over at Lifehacker they have a post about this:

Windows only: Ever wonder why your laptop's battery seems to die too quickly? The Windows Help blog points out a hidden command-line switch that generates a report with loads of helpful troubleshooting information.

The report lists all of the devices that are causing problems with sleep mode, explains the different power saving modes your computer supports, and even gives you detailed information on your battery—invaluable information when your system takes forever to go in and out of sleep mode. Generating the report is easy enough—just open up a command prompt in administrator mode using the context menu -> Run as Administrator option, and then type in the following:

powercfg -ENERGY The utility will take a while to generate the report, sometimes more than the 60 seconds it quotes you—but when it finishes you can open up the generated file in your favorite web browser. Once you've examined the report, you can figure out if you need to do some tweaking or update a driver.

Somebody else also suggested updating the DirectX drivers, though I have no idea what that has to do with sleep mode...

share|improve this answer
up vote 2 down vote accepted

It seems that the solution to this, in my case, was simply to setup a screen saver, haha. Ever since I set one up, I have not experienced this problem. Hopefully, I imagine this has been fixed in the final release (RTM) but for the release candidate, setting a screensaver works just great.

share|improve this answer
    
As an offtopic question, isn't the RC going to expire or about to expire? –  Nathan Adams Aug 15 '10 at 14:56

I had this problem as well, along with random cases of audio freezing and screens getting no signal in a full-on crash. I'd guess it has to do with the USB recognition/awareness of things plugged in, but for the moment just chalk it up to the fact that W7 is still Beta, and stuff like this will happen. Here's to praying for an RTM fix >.>

share|improve this answer
    
Thanks, that is actually a possibility. I still would like to hear some more input, but if I don't receive any more helpful information then I will mark your answer as the correct one. –  Jorge Israel Peña Jul 22 '09 at 18:46

I believe I have this problem worked out. I upgraded from XP Pro to Win 7 Pro 64 bit and was experiencing hangs when booting up and when waking up from sleep. Its actually an easy fix, believe it or not!

  1. Go to power settings, and somewhere in there theres a "turn off hard drive" option. Disable this. I read this can cause crashing on wake up.

  2. Make sure that your BIOS is set to S3 Sleep Mode!! This is important because some enable both S1 and S3 at the same time, which will result in a hang on waking your system up.

I think this is all I did, but I'm not writing this from my computer. Ive seen faster sleep times on both going into standby and coming out of standby though since I've taken these 2 easy steps, with a 0% hang up rate.

Good Luck,

matmatician

share|improve this answer

Was having same problem. In power plan settings, monitor set to turn off at 2hrs, put computer to sleep set to 'never', however, in advanced power settings hard drive was set to turn off after 40 mins. Changed this to about 1700 mins and all seems OK.

share|improve this answer

I had the same problem with my mouse locking after the computer came out of hibernation using Windows 7. I read all the technical responses on all the sites and nothing worked. I tried many suggestions and nothing worked.

I solved my problem. How? I removed my mouse and replaced it with an extra identical Microsoft mouse. No problem for the last 3 weeks.

You figure; I can't.

share|improve this answer

To resolve this problem in Windows Vista, run the powercfg -h on command at an Administrative command prompt to enable the hibernate feature and the hybrid sleep feature. To run this command, follow these steps:

  1. Click Start, click All Programs, and then click Accessories.
  2. Right-click Command Prompt, click Run as administrator, type powercfg -h on, and then press ENTER.
share|improve this answer

protected by Gnoupi Aug 15 '10 at 14:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.