Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an old Dell Dimension L866r which I flashed with BIOS version A14.

Now when I turn on the system it hangs with the full-screen Dell logo.

If I press Esc immediately after turning it on I get the POST screen and it counts up the RAM. Once the RAM test/count is complete, the system hangs.

If I press Del immediately after turning it on I get the POST screen and and the "Entering SETUP..." message. Then it hangs.

The A, B and C diagnostic lights are green. The D light is yellow.

I have tried removing the battery from the motherboard and leaving it out for a while. I also tried changing the password reset jumper. I didn't expect these to help and they didn't.

Is there any way under these circumstances to revert to the previous BIOS version or to otherwise recover from this problem?

share|improve this question
up vote 2 down vote accepted

Try to boot your board into emergency maintenance mode (usually known as Boot Block Recovery). In this mode the BIOS will only boot a minimal floppy disk boot block. This boot block will boot and run a floppy, and provides no keyboard input or screen output. So the restore process has to work completely automated. You will need a backup of your old BIOS of course and a prepared boot floppy with flash program and some automation code in an AUTOEXEC.BAT. To enter this mode, usually some obscure key combinations are to be held down during power-on, or an onboard-jumper needs to be set.

Another approach could be to find an electronic retailer and ask him to flash your BIOS chip with the backup image (you'll need to give that to him, too). Either take your complete motherboard there or CAREFULLY remove the BIOS chip yourself and take that to the retailer. Most electronic retailers are able to reflash these chips with special flashing devices.

PS: Boot Block Recovery probably won't work if the update overwrote the boot block or if that part of the BIOS wasn't write protected. Usually one cannot overwrite the boot block.

share|improve this answer
I haven't found the particular keystroke that initiates this, but I will keep trying. Unfortunately, the BIOS chip is soldered in and is surface mounted, so no go there. – Dennis Williamson Feb 19 '10 at 17:31
Since this problem occurs after the post is finished this can be due to wrong initialization of the CPU. I once had a similar problem with another board. Only option was to boot the board with an older BIOS chip (taken from another working board) and replace it with the flashed one while it was still running. Then I flashed the old BIOS back in. Unfortunately yours is soldered. But maybe you can try another compatible CPU. Also try removing memory (using only one bank instead of two) if that is an option. – hurikhan77 Feb 20 '10 at 13:54

As you have already tried to boot with the maintenance jumper (BIOS password reset jumper) in place and that still fails to boot, it sounds like you are out of luck.

The LED diagnostic pattern backs this up as it equates to "other error" instead of anything specific.

As you mention it is old, I doubt getting it replaced under warranty is an option.

You could buy a replacement motherboard direct from Dell but it costs around $200 which to me is rather expensive for an old computer.

I did find an identical part at TXcess Surplus for only $50. Part numbers match up, so it will be compatible. The Dimension L range all share the same motherboard.

For info, the Dell part number is 15JDG if you want to shop around yourself.

share|improve this answer
I would like to avoid replacing the motherboard, but this is certainly an option to consider. Thanks. – Dennis Williamson Feb 19 '10 at 17:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .