Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I current have a working XP partition a Dell XPS m1330 laptop along with a working Ubuntu partition. After launching the Windows 7 install DVD from within XP I run through the options for a custom install on a free NTFS partition. Everything seemingly works as it should and then my computer restarts. After choosing to boot into the newly created Windows partition I am given the Windows 7 splash screen only to be followed by the BSOD.

Here are the stop codes from the BSOD:

stop: 0x0000007b (0x80D86B58,0xc0000034,0x00000000,0x0000000)

Googling this tells me that it indicates an 'inaccessable boot drive'. Is it possible that its having problems booting from this partition due to the other existing partitions?

I'm thinking that there may be a windows recovery CD workaround this but I am not quite proficient in its capabilities.

This is what happens when I try to install by booting from the DVD

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I have an XPS M1330.

  1. Make sure the BIOS is up to date.

  2. Have you tried disabling AHCI for the hard drive? Note that this will likely break your existing OS installs, but I had tremendous difficulty installing any OSes on my M1330 until I disabled AHCI.

After formatting and beginning a clean install of Vista, I ran into a little problem where the machine would bluescreen immediately on startup after the install. I found that switching the hard drive interface from AHCI back to standard fixed that problem.

http://www.codinghorror.com/blog/archives/000927.html

share|improve this answer
    
The BIOS is running latest version (A15) and I've AHCI is disabled as well. Still having the problem. –  matheeeny Feb 8 '10 at 17:55
    
Update: Reset all settings in the BIOS and disabled AHCI and it all magically worked. Either there was some rouge setting that I muffed up or AHCI wasn't really being disabled. Either way its working now. Thanks!! –  matheeeny Feb 8 '10 at 19:35

If you want to keep your AHCI functionality you just have to get the right driver for that AHCI controller and provide it during the Windows 7 install (via USB key is probably easiest).

According to Dell that system uses the Intel Matrix Storage solution, but they (Dell) don't give out a Windows 7 version.

You can get the updated Windows 7 version of the driver directly from Intel.

From what I can tell the 32-bit Windows 7 install driver you want is available here, and/or the 64-bit version here.

Download it, and extract it onto a USB drive. Then during the Windows 7 install you can give it that driver so it can detect the HDD while it's in AHCI mode.

Once Windows is running you can get the Matrix Storage Manager application software from here. It monitors the drive condition and such. More useful in a RAID setup but hey. ;)

HTH

share|improve this answer
    
When I try to install by booting from disk I get suck at the first screen with no keyboard or mouse input. See this guy superuser.com/questions/105263/… for more details –  matheeeny Feb 8 '10 at 18:07
    
That's extra weird, and highly abnormal. If your mouse and KB aren't working during install (especially if you've tried an external mouse like you say you have in the other thread) then I'd say it's time to take the computer to where you got it from and get it fixed. :) –  Ƭᴇcʜιᴇ007 Feb 8 '10 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.