Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Linkstation NAS drive on a local network. Having just got a new laptop with Windows 7 Home Professional, I can no longer read anything of the drive. I've tried accessing the drive using \192.168.1.55\share, using ftp programs such as WinSCP, filezilla and even using firefox to hit ftp://192.168.1.55.

The really annoying thing is that through these methods I can see the files on the drive, counting out any kind of connection issues. I can navigate through the NAS file system, but as soon as I try and copy a file off the NAS, things just stop working. Accessing the drive through a Windows XP machine works fine.

So far I've tried:

  • Disabling firewalls
  • Adding the LmCompatibilityLevel key to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  • Using the 40 - 56 bit encryption instead of the 128 bit.

Has anyone got any suggestions of what I can check or try? This is driving me crazy and I'm totally out of ideas?

share|improve this question

migrated from stackoverflow.com Feb 6 '10 at 12:58

This question came from our site for professional and enthusiast programmers.

1  
I think the samba client on newer windows is not compatible with some custom linux builds anymore.. Your firmware needs to be udpated so it supports SAMBA2. It fixes security issues, permissions and generally they say its faster. Technically windows should fall-back.., but we all know Windows.. –  ppumkin Feb 1 '12 at 15:13

4 Answers 4

Same link as M4N, but a bit more useful for those who aren't members of QNAP forums (though I don't believe it will be the answer):

"Can not copy files from NAS to Mac" http://forum.qnap.com/viewtopic.php?f=13&t=1788

share|improve this answer

There are two problems with Vista/7 which may prevent connection to a NAS.

The first is due to changes in SMB since Vista, there are various patches and /or registry hacks around to fix this one (search for Vista SMB/SAMBA fix).

The second is due to changes in authentication. The real bummer with this second one is sometimes it appears to work, other times it doesn't.

share|improve this answer

I have no idea if this is related to your problem, but I also had problems accessing my QNAP NAS after I upgraded to windows 7. For me, changing the "LAN Manager authentication level" helped (as described in this forum post).

share|improve this answer

I have a similar config and strongly suspect this is because of a user name/password/workgroup mismatch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.