Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I hope I can get some new ideas to solve the issue. What I have:

  • AMD Phenom II X4 905e Box, Sockel AM3
  • Gigabyte GA-MA790XTA-UD4, AMD 790X, AM3 ATX
  • WD Caviar GreenPower 1,5TB SATA II
  • 4GB Kit OCZ DDR3 PC3-10666 Platinum Low-Voltage CL7
  • HIS HD 4670 iSilence4 DDR3 1024MB Native HDMI Dual-DVI, PCI-Express

Behavior: Everything works normally excepting the HDD accesses. The drive seems to get stuck in reading data (LED drive by mainboard is on for a while) then recovers and goes on. There is a delay of more than 30s sometimes. Often it is a matter of 5-10s. This does not seem related to the workload of the disk.

What I tried so far:

  • Use different SATA port: I switched from the SATA3 to SATA2 then the SATA driven by the CPU, no difference.
  • Turned AHCI off, drove the SATA in IDE mode, same behavior, now I felt like the HDD has problems
  • Deactivated energy saving settings (BeQuiet, ...), disabled 3 cores (msconfig) supposing some race condition or trouble with changing freqs, same trouble
  • With Windows7 Professional 64Bit, I installed the hotfix with no success. The problem description matches what I experienced, so I felt lucky but was quite in a sad mood after being deceived.
  • Burned the DLG 5.04f DataLifeGuard CD from WD to check the drive. All tests passed, to my surprise!
  • Installed an Ubuntu on the same drive i386 flavour. Drive still in IDE mode, exactly the same behavior. So the OS does not matter.

What I did not try yet:

  • I have a F2 BIOS and there is a F3a Beta, did someone have similar issues that were solved by this update? It is a beta so I fear upgrading a bit and I could find no release notes at all on the net, not really serious work maybe they had issues translating from Chinese???
  • Using another HDD drive

Does someone have other hints or a similar issue? Maybe it is neither the HDD nor the Mainboard/BIOS?

share|improve this question
up vote 3 down vote accepted

In my experience, this is a faulty HDD - the data reads are succeeding after several tries which is why you aren't getting errors.

I would try another HDD drive - or try that drive in another machine - to try and determine if it is faulty or not. I wouldn't trust it with data you need until you've established for sure that it is not the drive.

share|improve this answer
I am currently backing up everything and will report result of the try... – jdehaan Feb 7 '10 at 7:57
It is definitively the drive. I built it into another computer same behaviour. Reinstalled Win7 after a while surfing, or during data copy (3GB) the drive stuttered again. Driven in IDE mode, I tend to say that the situation is even worse. RMA... – jdehaan Feb 8 '10 at 12:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .