Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a secured wireless network and my Mac (Snow Leopard, 10.6.2) normally connects to it without any problems.

There is, though, an unsecured network frequently in range (called generically NETGEAR) which my machine will often, silently, connect to (despite the Ask to Join New Networks preference being checked). This is bad because it is not just a much slower connection, but it's passing my traffic over a router outwith my control. (This will even happen when I'm within 10 feet of the router so connection strength shouldn't be too much of an issue.)

So is there a way for me to specifically ignore this network and not automatically connect to it - I presume it's because it's unsecured that it is ignoring the Ask to Join preference?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

In Network Preferences → Advanced → AirPort, is the NETGEAR network listed as a preferred network? Try removing it from the list entirely.

I believe you're not being asked to join the network because your Mac has been connected to it before. If you remove it from the list of preferred networks, you should be asked before you join it again.

share|improve this answer
    
Thanks for that - it was in that list, so now I've disabled it ... let's see how it goes! –  Unsliced Feb 6 '10 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.