Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Specs: AMD Athlon XP 2400+ @ 1987 MHz / 2 x 512MB PC3200 DDR RAM / 128MB GeForce 6200 AGP / WD 160GB IDE HDD / FIC AM37 / DB: XP Pro SP3 & Ubuntu 9.10

Hi all,

I just installed Ubuntu 9.10 (within XP) on my desktop for the first time and I am trying to install the driver for my graphics card. I went to the NVIDIA site to download the Linux 32-bit version of the GeForce 6-series driver, which comes in a .run format. I double click on it and it begins to load in gedit, but it is unsuccessful because the character coding couldn't be detected. I tried running it in Terminal, but permission was denied. So, I searched how to open a .run file and came to here where I used the "chmod 755 [filename].run" in Terminal.

Now it can start uncompressing but now I get a new message saying "ERROR: nvidia-installer must be run as root". I have no clue what to do now... since I am a noob. XD

How should I be going about this? Thanks in advance! =)

share|improve this question
    
'Run as root' means you have to run the program in administrator privileges. In terminal you can do this with sudo ./[filename].run. Be careful in super user privileges... Before doing this try the method that Sathya suggested. –  egon Feb 6 '10 at 20:48
add comment

2 Answers 2

up vote 1 down vote accepted

Go to System->Administration->Hardware Drivers and check the box to enable the restricted drivers for your NVIDIA card if the option is provided.

If the restricted driver remains unactivated after attempting to activate it in the Hardware Drivers dialog, you may not have the appropriate linux headers installed to compile the driver. Ensure that the linux-headers-XXX and linux-restricted-modules-XXX packages are installed, where XXX matches the version of the kernel you are using (linux-image-XXX).

If the activation hangs on download/install dialog, you can install the driver using System->Administration->Synaptic Package Manager, make sure you pick the latest driver version recommended by the "Hardware Drivers" tool and all its dependencies. Go to Hardware Drivers tool and activate the driver you just installed.

( via )

share|improve this answer
    
Before there was nothing listed, but after doing a massive update to Ubuntu, everything worked out and the driver was installed successfully... Thanks! –  Wesley Feb 6 '10 at 22:11
    
@Wesley - Glad to know everything's fine :) –  Sathya Feb 7 '10 at 7:45
add comment

Forget about the file you downloaded.

Go to System -> Administration -> Hardware Drivers.

share|improve this answer
    
Before there was nothing listed, but after doing a massive update to Ubuntu, everything worked out and the driver was installed successfully... Thanks! –  Wesley Feb 6 '10 at 22:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.