Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I posted this on the Ubuntu forums and they had no good answer. I hope you guys have a solution!

On my relatively new install, it's booting into command line instead of X--again.

This is the reason I reinstalled in the first place. This has happened to me three times now.

So, I boot up and it gets past GRUB, past the glowing Ubuntu option, then it prompts me for my username, then password. I run:

startx

And that starts the GUI for about a minute, then it runs the GUI login system.

To add to the mess, the network-applet is not shown in the panel. Additionally, Chrome will not launch (I ran Firefox from the terminal).

What's the problem here?

share|improve this question
    
"happened before"; it was working correctly for a while, then this started? Did you install a graphics driver perhaps? –  RJFalconer Feb 6 '10 at 22:57
    
No, nothing. Just normal stuff for about a month, then it started doing this. –  user27439 Feb 7 '10 at 0:00
add comment

3 Answers

I'm curious as to what you mean by

So, I boot up and it gets past GRUB, past the glowing Ubuntu option, then it prompts me for my username, then password. I run:

startx

And that starts the GUI for about a minute, then it runs the GUI login system.

I read this as:

  1. I boot
  2. I login to terminal
  3. I execute startx
  4. X starts and I can mess around a bit
  5. X gets clobbered by GDM - the GUI login

If so then for some reason GDM is taking a ridiculous amount of time to launch. Could be authentication backend related or just about anything.

In your place I'd start checking the logs :

/var/log/Xorg.0.log
/var/log/auth
/var/log/daemon
/var/log/error
/var/log/syslog

At this point we're fishing to try and figure out what's going on on your system.

share|improve this answer
    
Yes, that is the right order. Nothing odd in the logs, I can attach them, if you'd like. –  user27439 Feb 7 '10 at 18:00
    
Well not terribly useful if there's nothing odd in the logs... -_- How about starting gdm manually in debug mode to see if the issue is there ? 1. sudo service gdm stop 2. sudo gdm --debug --timed-exit Hopefully with that you should either a) find some useful logging information and/or b) determine if GDM is slow to launch or if the slowdown happens before that. On another note, can you see the output of the startup scripts when you're booting up ? Does it seem to stall or fail somewhere ? Are you using networked authentication .. ie ldap ? –  delerious010 Feb 8 '10 at 0:00
add comment

If when booting your system it starts ubuntu in Terminal mode, try this:(I suppose you have the latest Ubuntu Karmic Koala)

First: Login via the Terminal(Username & password)

Second: Type:

sudo service gdm start

It should now load the Gnome Display manager with no problems. If you still encounter problems then find solutions in the Ubuntu Forms. I know you've try before but, try again.

share|improve this answer
add comment

Not sure whats the reason. you may want to check logs.

Anyways try this

  1. When starting up, in Grub, choose recovery mode
  2. It should give a menu list to choose various actions
  3. One of the action is setting up X display, try this option.
share|improve this answer
    
Nothing odd in the logs, though I'll try the recovery mode. –  user27439 Feb 7 '10 at 18:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.