Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Usually whenever I remove directories, "rm -rf " works. But sometimes I get this response:

"rm: examine files in directory / (yes/no)?"

Then I try "\rm -rf ", and that works. Can anyone explain why?

share|improve this question

migrated from stackoverflow.com Feb 7 '10 at 3:32

This question came from our site for professional and enthusiast programmers.

    
If it asks you whether to examine the files in '/', do you say 'yes' or 'no'? And does the machine continue to work afterwards? Be very careful about deleting everything under root when running as root; the machine keeps going for a surprisingly long time, but there comes a point at which you have to reboot - off a CD or something similar. – Jonathan Leffler Feb 7 '10 at 3:13

Someone, either your system administrator or your linux distribution (you didn't specify what form of unix you are using) has aliased rm to rm -i. Take a look at what man rm says:

-i Request confirmation before attempting to remove each file, regardless of the file's permissions, or whether or not the standard input device is a terminal. The -i option overrides any previous -f options.

You can see the actual binding of any command with the which command: which rm will say something like:

rm: mapped to rm -i

To execute the real rm, type \rm, as you have already discovered.

share|improve this answer
    
+1 At least someone explains what that -i actually means. – fretje Feb 7 '10 at 13:58

your rm command is alias, most likely rm -i.

check your shell alias.

share|improve this answer

Also consider calling it as: yes | rm -rf

share|improve this answer

Most of the new linux distro are making safy aliases

usually the rm command is aliased to rm -i.

You can remove that alias if you don't need it by doing rm='rm', also to make it automatic take a look at bash configuration files.

Good luck

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .