Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hooked up my External hard drive and it won't let me write new files to it, saying permission denied, and nothing is selectable on the permissions tab, saying on the bottom, You are not the owner.

How do I change the permissions? I'm using Ubuntu 9.10.

share|improve this question
1  
The question is not complete, because it doesn't state what filesystem is on the external hard drive. –  geek Feb 7 '10 at 6:08
1  
i'm reasonably sure this has been asked & answered before, but am not finding an exact duplicate. several related questions include the right commands, but are out of context for this question. in particular this one is almost the same question but not well-answered (yet): superuser.com/questions/85813/… ... others: superuser.com/questions/79813 .. superuser.com/questions/86685 .. superuser.com/questions/87062 –  quack quixote Feb 7 '10 at 7:17

3 Answers 3

Ubuntu allows you to access removable drives, but I have a USB 2.0 External Hard Disk that says it is NOT removable (thanks, Iomega.) You may be in the same boat here. If the hard drive doesn't show up as removable you're going to need to edit /etc/fstab to add a mount point for it, or mount it from the command line.

If you need to use it once, just mount it as root (with a reasonably unrestricted umask, say 000).

If you need to use it multiple times, eeither /mnt or /media is an acceptable place. Once you add the fstab entry (do it as root, and back the file up first) you'll be good to go.

Another option: If the file system is actually mounted read-write, use root to make a folder on the drive with the appropriate permissions, and have your user accounts write to that folder.

share|improve this answer

You're looking for the chown command. You'll need to use sudo to run the command, as it will require administrator privileges on files you're not the owner of.

share|improve this answer
    
this will only help if said external drive is formatted ext2 (or another filesystem that supports Unix-style ownership). will not help for FAT or NTFS filesystems. for those, a mount option is needed. –  quack quixote Feb 7 '10 at 7:19

Maybe the disk is mounted read-only?

Right click on the mount on your desktop, and see if there's an option to remount read-write. Otherwise see if you can mount it read-write from the command-line.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.