Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed the openSuse 11.2 , but i insert my pen drive to usb port it is not getting recognised and mounted,

I used following the command to prob the OS

lsusb = no results lshal |grep usb = not result

share|improve this question

2 Answers 2

Do you have a notebook? Which one?

I had the same problem with my Asus (F5 series).

Sadly, I only managed to work around this issue by recompiling the kernel (using SUSE's kernel .config file) with all core USB features selected to Y (inline) instead of M (compile as module).

This procedure is complex, but I'm sure, you will find a lot of information on the web, how to configure and compile a custom kernel.

share|improve this answer
    
Thanks for the info, i dont want to touch kernel , yesterday i was updating 11.1 suse to 11.2 suse , 11.1 crushed.i have to reinstall the 11.1 again. –  user27478 Feb 9 '10 at 21:18
    
Linux vendor expect the user of linux to become system adminitration first. :) –  user27478 Feb 9 '10 at 21:19

I've been having similar issues. Do you have the Device Notifier widget installed on your toolbar? Whenever I plug a USB drive in, I have to click on the Device Notifier and choose to open the drive in the Dolphin File Manager. It then mounts once I do that.

It is still annoying, because I like for such things to mount automatically. Based on googling the issue, I'm going to update to KDE 4.4 and see if that fixes the problem.

Update: I installed KDE 4.5 and it brings an updated Device Notifier. Right clicking on the icon to get to the settings gave me some options as far as determining whether or not to automount usb devices. It will have a list of devices that have been plugged in in the past. I haven't played around with it too much but you may have to specify settings for devices that have already been plugged in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.