Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running windows 7 64 bit with an EVGA 055 motherboard and an i5 Intel processor;

I have 2 4gig DDR3 ram kits installed, and windows only sees 4 gigs. Resource manager is informing me that i have a total of 4087mb, and 4096mb installed.

A while back, after taking out the ram and putting it back in, i was able to get windows 7 to see all 8 gigs of ram (which system spec tools do see, as does the BIOS), but 4 gigs was hardware reserved. Then I restarted and that went away. Now i am only seeing 4 total.

does anybody know where the problem could lie? i have been informed before that it could be an issue of a bug in windows 7.

share|improve this question

3 Answers 3

To me this sounds like hardware issue. Steps that usually resolve this are updating BIOS and reseting it's values to defaults.

If this fails, another thing to try is different memory chips.

I doubt that this is result of Windows 7 bug.

share|improve this answer

What kind of video cards do you have?

Check in BIOS, also you may want to play with the ram sticks (put in one at a time, then 2 at a time, then 3, etc, ONE of the sticks can be broken or two of them can be, its happened)

share|improve this answer

Go to Start -> Run -> type "msconfig" -> Boot tab -> Advanced options -> Tick Max Memory

alt text

share|improve this answer
2  
It's long been known that these performance "increasers" are actually BS. If that box was ticked, unticking it could help, but they are purely for debugging and testing, windows automatically uses all of your processors and RAM wherever it can. –  Phoshi Feb 7 '10 at 18:25
    
@Phoshi Sorry but ur wrong, I had the same problem as Squirrel and this solved it exactly. –  Chris Tarazi Feb 7 '10 at 18:28
2  
I could be wrong, but under normal circumstances this isn't how it works. If it is, there was some deeper issue that this happened to circumvent (In which case, it's worth trying, but it's not a proper solution) –  Phoshi Feb 7 '10 at 18:40
    
well, it didnt work anyway, i booted up with maximum memory checked at 8 gigs, and when i went to there again, it had automatically movied the maximum down to 4, so i unchecked it. Reinstalled drivers, but i have yet to boot one stick at a time. –  Squirrel Feb 9 '10 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.