Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to disable the "NetBIOS over TCP/IP" device in the device manager to free port 445. But after doing that my Internet stops working. I'm connected to a WLan router using DHCP on WinXP, and it is stuck forever in the "acquire network address" step.

Why does it misbehave like that? I don't need NetBIOS!

share|improve this question

1 Answer 1

NetBios uses ports 137, 138, and 139. Port 445 information is utilized by SMB over TCP. The SMB (Server Message Block) protocol is used among other things for file sharing.

Have you tried direct hosting of SMB over TCP/IP?

share|improve this answer
1  
"disabling on DHCP server" presumes a Windows product serving DHCP. i'm not sure how many WLAN routers run Windows Server 2003. –  quack quixote Feb 7 '10 at 19:38
    
Good point...I'll remove it from my response. –  Mark Feb 8 '10 at 13:17
    
I'll try that, but I doubt it will free the listening port 445 on my machine. I disabled the "NetBIOS over TCP/IP" device only because someone said it would free port 445. I checked the services, and "DHCP" depends on the "NetBIOS over TCP/IP" service, which might explain why my internet stopped working. Configuring a static IP configuration to circumvent DHCP didn't help, though. –  Buddy Casino Feb 9 '10 at 12:07
    
@user, You say configuring a static IP didn't help. Where are you getting your DHCP from? Your ISP? A local router? –  heavyd Mar 11 '10 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.