Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All of a sudden Windows 7 (64 bit) lost all DVD and CD-ROM drives. It worked fine for about a month, then I don't know what happened.

At first I thought it was a hardware problem - that my DVD-ROM had malfunctioned. But then I realized that Windows 7 no longer picked up on Demon Tools drives either. I can boot both Windows installation and Knoppix from the DVD-drive.

So it seems to be a general problem with "disc-media". When trying to reinstall the hardware DVD-ROM Windows recognizes the drive (though sometimes simply label it as "CD-ROM drive"), but then says something went wrong - with from what I understand is a default error message (39), claiming the driver has become corrupt.

I've tried every Microsoft recommended action, i.e. uninstall, reinstall, look for driver updates etc. etc., but with no luck.

Any tip most welcome!

share|improve this question
+1, device issues will be troubling users of W7 for a long time to come. – DCookie Feb 7 '10 at 21:06
up vote 4 down vote accepted

It could be a bugged upper/lower filter set by a DVD/CD-rom application:

  1. Go to run (or hit Win+R), type Regedit and click OK.
  2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}
  3. Right-click the key and Export it before making any changes
  4. In the details pane of Registry Editor, on the right side, delete UpperFilters and also LowerFilters.
  5. Restart your computer

(if it doesn't help, double-click the exported reg file and reboot to return to the previous state)

Other things to try:

  • Uninstall daemon tools and any other DVD/CD related tools (Remove StarForce, Remove Securom). One by one, with a reboot each time, to find the culprit
  • Use deviceremover to remove the culprit driver (and reinstall a good one). But be carefull with this advanced tool, it could damage your system
share|improve this answer
I uninstalled Daemon Tools, everything associated with GTA IV and SecuROM, which didn't fix it. Your Regedit-tip did the trick in the end, but I think uninstalling SecuROM helped. – Marcus L Feb 8 '10 at 20:48
You should add to "Other things to try": reinstalling the cd/dvd rom driver. That fixed my problem. I did it after steps 1,2,3,4,5 and removing StarForce, Securom. – tftd Jul 12 '12 at 13:29

I've seen serious problems with CD\DVD ROM drives that have been caused by various file system filter drivers becoming corrupt. Sometimes these are related to CD\DVD Burner programs and sometime it's content security (DRM) enforcement software that is installed with some games - SecuROM and StarForce are two examples. While most of these are fairly benign, they are quite intrusive by nature, uninstalls and updates sometimes fail and will lead to the whole CD\DVD driver stack becoming unstable or unusable.

If you open Device Manager - is the DVD reporting any errors? When you look at the Driver File details under the properties dialog for the DVD what driver files are listed and are they all present on your system? If any are missing try to track down the correct installer\uninstaller of the component in question and use those to fix the problems.

share|improve this answer
The drive is correctly identified in make and model, however the device status says: "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)" I've tried uninstalling, reinstalling etc. The only driver file is c:\windows\system32\drivers\cdrom.sys and it is indeed present at said location. The only thing I have installed that could cause any kind of DRM issues would probably be GTA IV. – Marcus L Feb 7 '10 at 20:46
As it turns out, GTA IV uses SecuROM. What I don't get though is that it has worked for months, but then all of a sudden just stoped. And it also effects Demon Tools drives. – Marcus L Feb 7 '10 at 20:50
SecuROM's website seems to have quite a lot of stuff relating to GTA IV, none obviously your issue but it might be worth running their diagnostic utilities. I know various DRM enforcement "utilities" like Securom really do not like to co-exist with Daemon Tools so looking on the Daemon Tools site for info on SecuROM would be a good place to start. – Helvick Feb 7 '10 at 21:17
If SecuROM is the cause of this, that'll be the final drop that'll make me stop buying PC games once and for all. And in that case, Sony will once again have proven they should not attempt to be a software company. Sony software is always a mess. I'll keep you posted. – Marcus L Feb 7 '10 at 21:32

I suggest that you follow the Drive Management steps here – read it carefully, it worked for me.

  • Right-click My Computer
  • Click on Manage
  • On the left side click on Disk Management
  • On the right side, find your optical drive and make sure that the drive letter it wants to use is not being used by another drive or maybe your card reader. If there is a conflict, right click on the optical drive and select change drive letter. Pick a letter, OK and if there is a disc in the drive the AutoPlay should immediately come up.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .