Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows Server 2003 64bits, and it has two IE8 inside, 32-bit and 64-bit.

When I run "iexplore.exe", debug in visual studio, clicking links, and etc, the 64-bit will popup and some plugins do not work.

How can I fix my system that it will always run the 32-bit IE by default?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

You should have "Internet Explorer" and "Internet Explorer (64-bit)" under Start/All Programs. You may examine these shortcuts by right-click and properties, to find how to run each version.

The path to the 32-bits version is probably something like this (I can't verify, not having a 64-bits system):
C:\Program Files (x86)\Internet Explorer\iexplore.exe

You can verify that the right version is running in Task Manger, where the running 32-bits process should be shown as iexplore.exe*32.

share|improve this answer
    
I know how to choose and how to run them. It is not what I am looking for. I have to know how to set the default. –  Dennis Cheung Feb 8 '10 at 13:51
    
@Dennis: The default browser is defined by the registry key HKEY_CLASSES_ROOT\http\shell\open\command –  harrymc Feb 8 '10 at 13:59
    
@harrymc HKCR\http control only the default application to handle URLs with http protocol. but it is not always the default browser, in some cases. For example, in older version of MSN messenger, it use OLE/ActiveX/COM+ (whatever you call it) to launch browser. I've faced few another cases like that, but I don't recall their name. –  Dennis Cheung Feb 18 '10 at 15:20
    
@Dennis: In my case command contains the browser. In any case, I don't see how it can contain an ActiveX or whatever, since these can't be invoked from the command-line. –  harrymc Feb 18 '10 at 15:39
add comment

You can just copy the IExplorer 64 bit from the Program Files directory to Internet Explorer 32bit directory at Program Files (x86) directory. And that's how you'll get rid of Internet Explorer 32bit.

If it won't let you - just rename the Internet Explorer 32bit directory and copy the 64bit to that directory.

You might need to "Take Ownership" on that directory and maybe remove the "Read Only" from it.

It worked great for me.

share|improve this answer
    
Just terrible advise. Don't do that. –  Oliver Salzburg Jul 5 '12 at 23:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.