Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My actual modem is Scientific Atlanta DCP2100r2.

Problem : Since public IP depends on the MAC address (like any usual dhcp I think), the modem is not giving an IP to a network card behind a bridge.

This is my configuration DCP2100 -> linux bridge with openvz containers -> other linux server running in a container.

IMPORTANT : I only get 1 ip addres, so the linux brigde doesnt have any IP assined. When the router dont have the cable link, it gives 192.168.100.* range IPS, the container gets IPs like 192.168.100.23 but when its connected to internet it doesnt get any public IP to the containter. However the bridge will get the public IP.

So I think, that the modem knows which network card has the physical link and want to get public IP via that MAC address and no the containter network card. If its like this, I have no possible way to solve this problem?

share|improve this question

migrated from serverfault.com Feb 8 '10 at 8:51

This question came from our site for professional system and network administrators.

1  
What exactly is the question you are asking? Is there some reason why you can't use a NAT? Where is the router in all of this? –  Helvick Feb 7 '10 at 0:27
add comment

3 Answers

up vote 0 down vote accepted

You need to put a router between your machines and the cable modem. This will receive the single IP you are allowed and do Network Address Translation (NAT) to allow any number of other machines connected to it to access the internet. A bridge or hub will not work because they aren't smart enough to deal with the single IP requirement.

share|improve this answer
add comment

Most likely your ISP will only assign one public IP to your connection. Presence of bridges or other stuff then has nothing to do with it.

share|improve this answer
    
yes but the machine behind the bridge dont gets the IP. thats why I put the observation "IMPORTANT" –  llazzaro Feb 6 '10 at 21:39
add comment

Similar to Chris Nava's answer I also believe you need some kind of NAT.
But maybe that's possible without plugging an extra piece of hardware (router) into your network: I found an article describing how to enable NAT for a container with private IP addresses.
I hope that helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.