Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So my problem is relatively simple. I have a host OS (Vista) that connects to a Windows 2008-based SSTP VPN. I have a virtualized guest OS, Windows XP, that I need to access resources over the VPN.

When a new VPN configuration is created in Windows, Windows sets it up as another connection in the Network & Sharing Center. However, VirtualBox config is unable to see this connection when choosing a connection to bridge to.

My local network is 192.168.1.x My remote (over VPN) network is 192.168.10.x

The problem is that the guest takes its DHCP / IP's from my local network (not remote VPN), so the IP address assigned to it is usually 192.168.1.x. Virtualbox is not properly seeing the VPN.

Any ideas on how to make it work properly? Both the physical adapter and the "virtual" adapter (VPN) have the VirtualBox Bridged Networking Driver enabled and checked.

Thanks in advance.

Update: Using "NAT" instead of "Bridged" on the VirtualBox configuration worked -- but only partially. Now it connects and accesses resources, but new problem arises. The virtual instance itself is given an IP address of 10.0.2.x -- we don't have any servers in this range. What's up with that? What do I need to do to get it in the 192.168.10.x range?

Or rather, I want to access that machine from other machines on the network. How?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Switch the virtual machine's network interface from bridged to NAT and it should work fine.

share|improve this answer
    
Worked perfectly. –  Joshua Feb 8 '10 at 18:00
    
+1 as it worked, and LOVE your profile pic! (Look at mine...) –  William Hilsum Feb 8 '10 at 18:26
    
Update: It connects and accesses resources, but now I have a different problem. The virtual instance itself is given an IP address of 10.0.2.x -- we don't have any servers in this range. What's up with that? What do I need to do to get it in the 192.168.10.x range? –  Joshua Feb 9 '10 at 22:59
1  
Does the remote end of the VPN need to initiate incoming connections into the virtual machine? If not, you don't need to do anything; your VM software will handle the masquerade. If so, you'll need to either connect to the VPN directly from the guest machine or have the host machine forward incoming packets to the guest machine (in essence, the host machine will simply be a router/firewall in front of the guest machine). This is easy with iptables or ipfw, but I don't know how to do it in Vista. –  John Douthat Feb 10 '10 at 2:33
    
Ah bingo. That was a big help. I recall that there is a configuration in the VPN that does the routing -- I will look there. Case closed as I need to do some more research :) –  Joshua Feb 11 '10 at 22:03

I had the same issue. I got VPN working in the guest by going into the Network settings in Oracle VM manager. I changed "Attached to" to "Bridged Adapter." I then selected a different adapter type than what was listed and set the promisuous mode to allow all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.