Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Having a bizarre problem on my Mac and was hoping you guys could help.

My main user that I use every day is no longer allowed superuser privileges in the GUI. For instance, if you go to System Preferences/Accounts and 'Click the lock to make changes' it will always reject the password I enter with the message 'Try entering your information again.' and an 'OK' button.

I figured that the user had dropped out of the admin group but that is not the case. When I use 'groups' you can see that it is clearly there. I also have no problems using su & sudo from the command line. When you check the user with dscl it is still in the admin group.

I added another admin user from the command line using dscl and used that to remove and then re-add admin privileges from my main user but that didn't work.

I've also tried running Disk Utility and Repair Permissions but that hasn't worked either.

Am running a MacBook (early '09) with the latest version of Snow Leopard (10.6.2)

Any ideas?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I had an issue that looks the same and I finally figured out my problem.

I had been using dscl (Directory Services Command Line utility) to setup groups and accounts for an Oracle software installation on my Mac. I then tried putting myself into the same group as the owner of the software. Not knowing what I was doing, I inadvertently assigned more than one PrimaryGroupID to my user account.

Somehow that prevented me from doing admin tasks, even though I was a member of the admin group. What clued me in on the problem was the word "primary" in PrimaryGroupID ("primary" implies "one"). So after removing the extra PrimaryGroupID assignment from my user account, I could resume admin operations on my Mac.

share|improve this answer
    
This sounds exactly the problem. I've just done an oracle install and have just been messing about with the pids. Thank you. –  john Feb 13 '10 at 11:26
    
Yup, you hit the nail squarely on its head. Shame on those who voted down this answer. –  john Feb 13 '10 at 18:37
1  
Look at the edit history. It seems he initially posted "Did you ever figure out your problem? I seem to be having the same issue here.", and then updated it when he solved his problem. The "Me Too" Answer is what got voted down. –  Fake Name Feb 14 '10 at 1:25
    
@Fake Name: correct. it's possible (and encouraged!) that the downvoters will remove their downvotes (or even change them to upvotes!) now that he's edited it into a real answer. –  quack quixote Feb 14 '10 at 3:18
    
They oughta upvote you for your effort @~quack ;-) –  Ivo Flipse Feb 15 '10 at 6:19

You also need to be part of the staff group.

  • When you go to System Preferences -> Accounts -> unlock preferences if needed -> right clic on your account -> select "Advanced Options" :

Are still member of the staff group ?

  • When you go to System Preferences -> Accounts -> click on your account :

Is there a tick in the box "Allow to administer the computer" ?

  • When the box to authenticate yourself appears, is the full name correct ?
  • Did you change your username/full name recently ?
  • Try to authenticate with your username instead of your full name when this box appears.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.