Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows Virtual PC on Windows 7 (host) running Windows XP (as the Guest O/S). I'm trying to get the Microphone working.

When I Enable Integration Features:

  • Microphone does not work
    • When I run the Sound Recorder, the record button is disabled. If I look at Sound settings, there are no options for the Mic (it's all disabled "grayed out").
  • Speakers work
  • Copy & Paste works
  • Drag & Drop does not work.

When I Disable Integration Features:

  • Microphone and speakers work
  • Copy and Paste does not (as expected)

Drag'n Drop copying does not work in either situation.

There seems to be no way to assign a folder on the Host to be a drive letter (accessible via just the drive letter (e:\, etc.) on the Client.

What I've Tried

  • Verified that the Windows XP Mode Virtual PC guest also has the same symptoms (Mic doesn't work) and audio out (speakers) do work.

  • Uninstall and Reinstall the Integration addin for Virtual PC

  • Changing a setting in the .vmc file:

  1. Ensure that the VM (and may be even vpc.exe) is not running.
  2. Go to %LOCALAPPDATA%\Microsoft\Windows Virtual PC\
  3. Open Virtual Windows XP.vmc file
  4. Go to the tag and add a sub tag: "
<audio_redirect
> type="boolean">false</audio_redirect> "
  1. Start the VM/Virtual Application This solution was from a Microsoft Forum

Also, this happens on every Client I have within Virtual PC (with several O/S's on the Clients: XP, 7 and I think Vista)

UPDATE: I seem to remember being told that VPC only supports a USB Mic, not the built in Mic.

share|improve this question

2 Answers 2

up vote 1 down vote accepted
+50

This might help (from Recording in a virtual machine/microphone) :

Found a setting in the .vmc where I changed from false to true:

<sound>
  <sound_adapter>
    <enable type="boolean">true</enable>
  </sound_adapter>
</sound>

I don't get the built in microphone to work (why??), but the microphone in my MS web-cam works.

The above solution should be tried both with Integration Features enabled/disabled. Some people had luck with completely uninstalling and reinstalling them and rebooting,

The only way of really getting around the virtual hardware in the VM that I am aware of, is the use of USB devices which should transparently work as designed within the VM.

If you are thinking about giving up on Virtual PC, then I suggest VirtualBox, which is both free and excellent quality.

share|improve this answer
    
The Webcam is almost certainly USB which is why the Mic in it works. –  Clay Nichols Dec 24 '10 at 22:22
    
This worked but also required the setting in my post (<audio_redirect > ). But even then, the sound was garbled. Not sure about why that is. –  Clay Nichols Dec 24 '10 at 22:50

Use VMware Workstation. This is not a free product. You have to buy that from VMware.

VMware Workstation 7 is optimized for maximum performance when running on 32-bit and 64-bit Windows 7 PCs. Supports Flip 3D and Aero Peek to show live thumbnails of your virtual machines. Run legacy application with 3D graphics, faster performance, and tighter desktop integration better than Windows XP Mode. Get shared folders and drag and drop convenience.

Source: https://www.vmware.com/products/workstation/

share|improve this answer
    
VmWare is FANTASTIC. So much better than Virtual PC on Windows 7. It Just Works! (VPC back on Win XP was actually pretty good). –  Clay Nichols Feb 27 '11 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.