Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to mount an AFP network share from my NAS so that multiple users can have access when using Fast User Switching (FUS).

Once I mount the share as User1 and log into User2's account the mounted share will show up but is not accessible. Same the other way around.

Both users are in the group wheel. Is there any way to specify permissions of the newly mounted share? I looked into the man pages of mount, fstab, mount_afp but couldn't seem to find any way how to specify the permissions of the mounted share.

The problem is e.g. if you have a shared iTunes library with music files on say an AFP network volume called music that the first user will mount that under /Volumes/music. If the second user decides to mount it as well (while the first user has still mounted it) a new mount point will be created and the volume is mounted to /Volumes/music-1.

Since iTunes stores the file path as something like /Volumes/music/album/artist/title.ext in an XML file, iTunes will say it can't find the file even though the network share is mounted (but the path is wrong now and the user doesn't have access to the other mount).

Any thoughts on this issue? Any help greatly appreciated!

share|improve this question
    
Did you ever solved this? This seems like an issue that you'd have solved by now. :P –  Cawas Mar 15 '10 at 21:23
add comment

2 Answers 2

I think what you're going to need to do is have the mount done automatically before logging in, or handled by Mac OS X's automounter called autofs. Here's some general info on setting up automatic mounts.

This thread over on the ReadyNAS forum may describe something closer to exactly what you're looking for.

Also note, as in one of the other replies here, make sure permissions are done appropriately on the NAS such that all your users can read/write to the afp mount.

share|improve this answer
add comment

I'm not sure if your situation is similar but I use netatalk on my NAS; I had to make sure permissions were set allowing both users access in the AppleVolumes.default config file in order for the share to mount properly on my mac so that both users have access to it.

Also I think by default User2's desktop won't show the share, you have to manually go to it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.