Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After a recent kernel panic & restart, Spotlight no longer seems to know anything about the files under my /Applications folder. I used to launch Safari.app, Opera.app, Textedit.app, etc via Spotlight as a matter of routine. Now, I get "No results found" for all of them (except Textedit.app, which launches a demo text editor from a Qt installation). The programs are still there & still launch directly from Finder.

I've already run disk utility & verified the disk, no issues. I repaired disk permissions, which made several changes, but to no effect.

Is there anything else I can do, short of re-installing MacOS?

Update: I already verified that "Applications" was still checked in my Spotlight preferences. It was still returning applications located elsewhere (the Qt textedit sample app), so that shouldn't have been the issue.

A few hours later it resolved itself; I guess there's a background process running on some interval.

share|improve this question
    
see also superuser.com/questions/8414/… –  charles Apr 4 '12 at 17:35
add comment

5 Answers

up vote 2 down vote accepted

To completely rebuild the index, run the following from Terminal.app:

sudo mdutil -E /

This works, although it takes some time.

share|improve this answer
add comment

Did you make sure that in System Preferences - Spotlight, the Applications category is still checked ? If it still is, try unchecking and then rechecking it.

share|improve this answer
add comment

I solved the same problem by adding /Applications to Spotlight's Privacy tab (this forces Spotlight to delete any index for the folder), waiting a few minutes, then removing /Applications from the Privacy settings. Spotlight should then reindex the folder.

share|improve this answer
    
I didn't get a chance to verify this before the problem resolved itself, but this was the only answer that didn't mention the "Applications" checkbox, which wasn't my issue. –  pra Feb 9 '10 at 23:15
    
Didn't work for me. OS X 10.6.6. Waited 10 minutes after adding /Applications in the privacy tab, to removing it again. Allowed two hours to rebuild, but still nothing. –  Johannes Hoff Mar 5 '11 at 14:27
    
Finally found something that worked for me - posted as a separate answer. –  Johannes Hoff Mar 11 '11 at 14:17
add comment

In my case, the 'Privacy settings' tricked failed, with an error message when trying to remove the hard drive from the privacy list, indicating my whole index was really messed up.

The solution was to type the following in the Terminal:

`sudo mv /.Spotlight-V100 /Spotlight-V100-old`

(you will need to type an admin password for that)

and then restart the computer. This will force a reindex of your data, since the above just removed all references to the spotlight index.

You can also then clean up the folder "Spotlight-V100-old" that will now appear on your hard drive.

This "nuclear" option requires admin privileges.

share|improve this answer
    
Thank you! This was the only solution that worked for me as well. –  Mark37 Apr 19 '13 at 13:04
add comment

There's an Applications checkmark in the list of things to include in Spotlight (System Preferecens, Spotlight).

share|improve this answer
    
Already checked that, forgot to mention it. –  pra Feb 9 '10 at 23:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.