Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Parallels build 4.0.3384 (the latest at the time of writing), on Mac OS X 10.5.7, with Windows 7 RC1 as my VM

I am unable to copy and paste from the host to the VM and vice versa. This is really annoying, any ideas?

share|improve this question
Which copy/paste methods have you tried using? Just wondering if you found that right-click copy/paste worked but keyboard ctrl-c then apple-v (etc) didn't...? – robsoft Jul 22 '09 at 11:08
All of them ... :-) – Bruce McLeod Jul 22 '09 at 13:36
[Chealion, related to the tag cleanup, maybe you're interested in this:… – Jonik Jul 22 '09 at 20:44
up vote 4 down vote accepted

Ok I just sorted this out. I shut the machine, then went configure > Features > Services

Then unchecked Share clipboard, then ok. Closed parallels so the machine configuration saved to disk.

Opened parallels went back and re-selected Share clipboard then fired up the machine and ... ta da ... fixed.


Well no it wasn't fixed as the problem came back, however upgrading to Beta5 has solved it 100%

share|improve this answer
this worked on build 7.0.15052 It's funny that these clowns haven't fixed this same bug yet eh? lol – thatjuan Dec 5 '11 at 5:23

I found that if you have .NET 3.5 installed on the Windows VM, it will prevent copy/paste from working. Remove 3.5 (2.0, 3.0 seem fine) and it should fix it. At least that's my experience.

share|improve this answer

For those who are having issues with ClipBoard Copy/Paste between Windows and Mac OS X, my problem was that I enabled "Isolate Mac from Windows" option under Security in Configure/Options tab.

Disabling that and rebooting the guest OS seems to have taken care of that problem.

share|improve this answer

Sometimes reinstalling "Parallels Tools" helps.

Select "Virtual Machine - Reinstall parallels tools" in the menu, while your VM is running.

share|improve this answer

You must log in to answer this question.

protected by random Sep 24 '12 at 1:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .