Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an LDAP server configured for in Thunderbird's address book (ldap.example.com). I'd like to use the SSL version, so I checked the 'Use SSL' box. It starts to work, but I get a certificate warning in response. Okay, sure, I know that server uses a funny certificate, so I'll add it.

I found the 'Add Security Exception' box readily enough, and it asks me for a server location. But I don't know what to put in there. The dialog box starts with https:// in it, but https://ldap.example.com doesn't work, and neither does anything like imaps:// or ldap:// or ldaps:// (is that a real protocol name? well, I tried it). LDAP really is the only service this server provides.

How can I get Thunderbird to read the certificate?

share|improve this question
add comment

2 Answers 2

The Mozilla Knowledge Base priovides instructions on what to do if a certificate is not trusted by Thunderbird. You will need a DER encoded .cer file to import, or if you can get Internet Explorer(Windows only obviously) to accept the certificate, the KB has instructions on how to export one.

  1. ...go to "Tools -> Options -> Advanced -> Certificates -> Manage Certificates... -> Authorities". (In Mozilla Suite, go to "Edit -> Preferences -> Privacy & Security -> Certificates -> Manage Certificates... -> Authorities".)
  2. Select "Import", select the file you saved above, and click "Open".
  3. Read the warning and select for what purpose you trust the certificate.
  4. Click "OK" if you trust it. It should now be installed.
share|improve this answer
    
Alas. I'm doing it from Linux, and... Mac. :) –  fennec Feb 11 '10 at 0:38
add comment
up vote 1 down vote accepted

In subsequent exploration I discovered that you can simply provide the URL https://ldap.example.com:636 (636 being the SSL+LDAP port) and Thunderbird will do the SSL negotation necessary to get the certificate, drop the connection, and never realize that it's not actually talking HTTP.

I'm going to file something with the Thunderbird bug tracker suggesting they take ldaps:// as a protocol specifier, instead of using that silly hack.

share|improve this answer
    
bugzilla.mozilla.org/show_bug.cgi?id=436318 (someone beat me to it) –  fennec Feb 11 '10 at 17:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.