Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up an old computer as a NAS/fileserver. It contains all my video files. These files are accessed by a separate HTPC hooked up to my TV (also running Windows 7). Everything was working great until today.

Most of the folders on the main hard drive are older. They were created before this latest PC build (and installation of Windows 7). The old folders I can access through the HTPC and edit as I need to.

Any new folder though, I cannot edit via the HTPC. I keep getting this error message: "You require permission from Dinosaur\d1 to make changes to this folder" (Dinosaur is the name of the fileserver; d1 is the main user on Dinosaur)

Attached is a screenshot of the Permissions of an older folder (on the left) and a newer folder (on the right). Any new folder I create has the same Permissions as the folder on the right and cannot be edited via the HTPC. The older folders can. I've tried adding "Authenticated Users" and "Users" to the new folder Permissions, but that didn't work.

What do my permissions need to be, and how can I set it so those are the default set when creating a new folder?

alt text

The old folder has permissions for the following users:

Authenticated Users
SYSTEM
Administrators
Users

The new folder has permissions for the following users:

SYSTEM
Home Users
d1
Administrators
WMPNetworkSvc

I set all the users permissions for the new folder to Full Control with no luck.

share|improve this question
1  
post a link to screenshot –  at. Feb 9 '10 at 19:05
    
Just comment the link and I'll edit it in. But another question: are you using Homegroups? –  Ivo Flipse Feb 9 '10 at 19:11
    
I am using homegroups, but the permissions issues still apply. –  johnnycakes Feb 9 '10 at 20:11

2 Answers 2

up vote 1 down vote accepted

Try granting Full Control to Everyone.

What user are you connecting to the server as?

share|improve this answer
    
I added Everyone and gave it Full Control. No luck. How do I connect as a different user? –  johnnycakes Feb 9 '10 at 20:02
    
This worked when I set the parent folder to Everyone and gave it full control. Giving sub-folders Everyone did not work. –  johnnycakes Feb 25 '10 at 21:48

For some reason the "authenticated user" entry is being replaced by the WMPnetworksvc. It happened to me when I added these particular sources (movies, music, photo's) to Windows Media PLayer 11 libray in order to share them over Upnp.

How to structuraly solve it; please let me know as I still encounter problems..

I always hated WMP, and trying it again causes me bad headaches!

one hint that helped a little was to set "User Account Control Settings" to absolute minimum.. Good luck on that!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.