Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running kubuntu 9.10 and every time I log in auto eth0 is used instead of my custom connection called "batnet". I have batnet set to automatically connect, but despite this it is ignored and the default auto eth0 is used instead. This would be fine IF I could somehow figure out how to define a static ip for auto eth0. I would prefer to just make the 'batnet' connection default. How can I do this?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

For static assignment on Debian-based systems, you need to edit /etc/network/interfaces.

example:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 208.88.34.106
        netmask 255.255.255.248
        broadcast 208.88.34.111
        network 208.88.34.104
        gateway 208.88.34.110

to change it back to DHCP:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp
share|improve this answer

You could put a script in /etc/init.d/ to run on startup that would turn off eth0;

sudo ifconfig eth0 down
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.