Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It's happened again: Firefox started letting new windows open as new windows and not capturing them in tabs instead. So of course JavaScript popups work properly, but my tab preferences are not correct. Open those new pages in tabs, always, please.

This happened before. And I fixed it with an about:config hack.

if you open about:config in your address bar, you can change the setting manually. Change: browser.link.open_newwindow Mine was set to 3, which told the popups to always open in a new tab.

Niceness. It's a pretty easy fix. Set it to 2. I just wonder what changed it to 3. Wasn't me.

So I set it to 3 again. And now links always open in a new tab. Good. And now Javascript popups come up in a new tab. Bad. This is extremely annoying. This shouldn't happen. Popups that are supposed to be popups should pop up! Anybody have a solution (and an explanation)?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Setting browser.link.open_newwindow.restriction to 2 might fix the problem:

2 : Divert all links according to browser.link.open_newwindow, unless the new window specifies how it should be displayed.

share|improve this answer
    
Yes. That did it. Thank you!!!!!! Now what screwed it up in the first place? –  Nathaniel Feb 10 '10 at 17:16
    
@Nathaniel: No idea at all. –  harrymc Feb 10 '10 at 17:18
    
I don't really know either. I recently installed a couple tab related add-ons (and uninstalled them), but I don't remember if this started before or after. Thanks for the answer. –  Nathaniel Feb 12 '10 at 1:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.