Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up port forwarding with my Comcast cable modem, an SMC 8014. Normally this is pretty straightforward (give a port range, tell it to forward to a LAN IP) but for some reason it doesn't seem to be passing traffic through on this box. :(

My Setup

  1. I have Comcast business-class cable Internet with 1 static IP address
  2. They gave me an SMC 8014 gateway
  3. My laptop is plugged into the gateway via an ethernet cable
  4. My laptop gets an IP like 10.1.10.66
  5. I logged into the 8014, went to the admin page (Firewall settings -> Port Configuration tab -> Port Forwarding menu), and added a forwarding rule for a public range 4000-4000, and a private range 4000-4000, all protocols, and used my LAN IP

Simple Tests

  1. If I go to http://www.whatismyip.com/ my public IP is indeed my gateway IP, e.g. 173.x.x.x
  2. I can ping the public IP, e.g. ping 173.x.x.x
  3. If I run a web server on my laptop, at say port 4000, I can go to my LAN IP just fine, e.g. http://10.1.10.66:4000
  4. If I try to get to web server from the gateway it fails, e.g. http://173.x.x.x:4000

... Is there something I'm missing? Is there something else I have to do?

(Note: I did notice that on the Port Forwarding rule I created I could not click the Enable box and get it to stay "on".)

Thanks!

share|improve this question
    
She is using port 4000, not 8080, although your Note that you could not click the Enable box is a bit disconcerting. I would expect your problem is related to that check box. –  heavyd Feb 10 '10 at 21:14
add comment

4 Answers 4

up vote 1 down vote accepted

It sounds like the SMC 8014 does not know how to route the packets back to you. Port forwarding on basic routers normally only forwards traffic from a WAN IP address to LAN IP address. I think in this case, because you are trying to connect from a LAN IP address to a WAN IP address, the data is lost because the router does not have any LAN to WAN port forwarding rules set up. Only WAN to LAN. Some routers are clever and do not have this problem.

It would be worth asking someone to test the WAN IP address to see if they can connect. I checked the setup on portforward.com and I cannot see any other settings that need to be changed on the router, beyond what you have done.

Ah ha.. I'm not going completely crazy. There is a post on this exact problem here on superuser which explains it much better than I can.

share|improve this answer
    
Thanks for the tip on the other Super User post---I'll read it in depth. In my case I'm trying to get a computer on the Internet to be able to talk to one of my laptops on the LAN and the gateway is doing its usual NAT. But you have me wondering if it's the case that things are in fact working OK but because I'm connecting from the LAN to begin with the gateway is getting confused. I'll try to connect from outside the office... Thanks again! –  Amy Feb 10 '10 at 21:57
    
Sorry, I should have just posted the link without all my confusing rubbish before it :-p I think you're right and it wouldn't surprise me if it is indeed working okay from out on the internet. The official terminology is "NAT loopback/reflection" if you wanted to really read up about it. –  Kez Feb 10 '10 at 22:14
    
kez, cool! Yup it turns out things were working OK---because I was testing from the LAN! I was able to use a computer on a different network access it just fine. –  Amy Feb 11 '10 at 21:46
add comment

Actually, to port forward ANY static IP device within the Comcast SMC8014 or SMCD3G Internet Modems this can be easily performed as follows:

  1. Log into SMC cusadmin web user interface
  2. Click left-side Firewall link, then top Port Forward Tab
  3. You will then see 3 links one of which is Static IP port management
  4. This is where you can specifically port forward application specific network used port to be opened or blocked.

This will enable your Static IP Devices (s) to be able to have remote access through your SMC WAN Static IP gateway device directly through and into your Static IP device(s).

share|improve this answer
add comment

There should be a setting called "DMZ", just input your static ip and then check the enable box. All of your ports should be forwarded.

share|improve this answer
add comment

If you are in a situation where you just have to have the LAN to WAN lookup and you have a local DNS server available, then you can configure the local DNS server to forward all DNS traffic to, say, Google's DNS Servers, add your domain as a new forward lookup zone, and add a host (same as parent) to the target local ip address of the device you're trying to connect to. Then, change the Primary DNS server in the gateway to the local ip address of your local DNS server, using Google's DNS server as a secondary. Then, run ipconfig/renew on all connected devices. Now you will be able.

Another option is to edit the host's file located in systemdrive\window\system32\drivers\etc and add your host name there followed by the local ip address of the target device.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.