Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, this is a very strange problem.

I have a dual-monitor setup at my workplace, and recently shifted one of the monitors to vertical position, like this:

alt text

Now, I use Ultramon to display different wallpaper on each screen. Basically, behind the scenes, Ultramon creates the following image file, and sets it as a 'tile' wallpaper:

alt text

(The two shades of gray represent the two images that I've used).

Now, here comes the strange bit: when I lock my computer (or even just press Ctrl+Alt+Del), Windows forces the upper-left corner of my wallpaper to align with the upper-left corner of Monitor 1, so instead of seeing the two images on my two screens, I see the bit of white image on monitor 1, and the lower part of the image in monitor 2 is cut (because that image is 'pushed down').

I have tried disabling Ultramon completely, and as far as I've discovered, this behavior is inherent in Windows XP - the operating system aligns the wallpapers differently when I work normally, and when I go to the Alt+Ctrl+Del menu.

Does somebody know this, and knows how to circumvent this? currently, I've changed my setup so that Monitor 1 is vertical, and Monitor 2 is horizontal, so the problem doesn't happen. It's also possible to bypass this problem if I move Monitor 2 downwards, so that its upper edge is aligned with Monitor 1, instead of its lower edge - but I can't work like this.

share|improve this question
    
Use Actual Window Manager instead, beats Ultramon by a country mile. i'm using a similar setup (H + V + V) and have no problems with different wallpapers. here's a 60 days trial: softpedia.com/get/Desktop-Enhancements/… –  Molly7244 Feb 13 '10 at 14:38
    
You could also give a try to Display Fusion, who supports different wallpapers per screen. –  Snark Feb 13 '10 at 14:53
    
If you have an nVidia craphics card, the nView utilities support multiple desktops as well, and don't have this problem (I think). –  Fake Name Mar 11 '10 at 7:41
add comment

3 Answers

In Control Panels > Display Properties > Settings are the monitors aligned like you wish?

I'm not familiar with UltraMon so I'm just guessing that maybe when you lock your computer, the OS takes over the monitors from UltraMon (a user process) and it's in the OS where you'll find a way to also configure for the locked situation.

share|improve this answer
    
yes, the monitors are aligned as I wish. again - this situation happens even when Ultramon is disabled. –  idan315 Mar 11 '10 at 20:11
add comment

Maybe you can get the normal desktop and the locked/Ctrl+Alt+Del desktop to look the same with a centered wallpaper instead of a tiled one? (You might need white borders on more sides to get it working.)

share|improve this answer
    
I will give it a try, and see how this works. Thank you. –  idan315 Mar 11 '10 at 20:11
add comment

Does the alignment fix itself when you unlock the machine, or does it remain out of kilter until you reset the wallpaper using Ultramon (or by other means)?

If it reverts back to the desired state automatically then I'd be inclined to say "just live with it" as you aren't going to be in front of your machine much when it is locked.

If it doesn't revert back automatically, you could try automate resetting it back to how it should be. Perhaps a small .vbs or .js script that calls UltraMon's COM interface (mentioned here) to set the wallpaper settings to their correct values, called regularly as a scheduled task (I think once per minute is as granular as this can be) that is set to only run while the user is logged in?

In either case I suggest that you report the issue to the authers of Ultramon either as a bug report or feature request - it could be something that affects a number of their users (though they won't know if noone has reported it) and might be something they can fix/change easily in time for their next minor update release.

share|improve this answer
    
The situation reverts itself once I unlock my computer. I know it is possible to live with it, but I still want to know if this is a bug/strange behavior in windows, or something that I don't deal with correctly. As I mentioned - this also occurs when Ultramon is disabled, so this is not an Ultramon issue. –  idan315 Feb 14 '10 at 0:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.