Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I accidentally deleted one of my source files from on a Mac using rm. I could rewrite it - its not worth buying a program to recover this one file.

But, is there a free alternative that could restore my file?

share|improve this question

closed as off topic by techie007, Daniel Beck Aug 15 '12 at 20:14

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

You are not using TimeMachine, are you? –  Thilo Feb 11 '10 at 7:22
Its on the Mac, but not set up. Snow Leopard –  Casebash Feb 11 '10 at 22:35
Related: How to recover deleted files in Mac OS X? –  galacticninja Oct 11 '13 at 3:38
Why was this question closed? –  Casebash Oct 11 '13 at 5:14
add comment

3 Answers

up vote 3 down vote accepted

As Mac OS is more or less a normal UNIX, you can follow these instructions. But I wouldn't go into single user mode, as I don't know how Mac OS behaves here.

Or try Data Rescue. I read somewhere that one can recover one file at a time with the demo version.

Besides Time Machine, you should also consider to use a version control system like Git which adds a lot more benefits than just "recover" accidentally deleted files.

share|improve this answer
I tried the unix instructions, but got the message resource busy :-( –  Casebash Feb 11 '10 at 22:52
@Casebash: This is because the hard disk is in use (I guess it is your main hard disk). You could boot with a linux live cd like Knoppix or Ubuntu and try again. –  Felix Feb 12 '10 at 0:31
Ended up just rewriting the file. Accepted this answer as it is the best here, but I haven't verified that those instructions worked –  Casebash Feb 20 '10 at 6:26
add comment

I would comment but I can't. Did you try using the disk device instead of the partition? I think that should work.


sudo grep ... /dev/disk0
share|improve this answer
add comment

Boomerang allows a free trial - might be enough to get a small file back.

For the future Time Machine!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.