Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried gnome-shell in Ubuntu by using the gnome-shell --replace command. It works well but I think the font size in the shell panel is too big.

Is possible to custom the font size in gnome-shell panel?

share|improve this question

migrated from stackoverflow.com Feb 11 '10 at 6:53

This question came from our site for professional and enthusiast programmers.

    
you're going to have better luck on superuser.com –  Mark Elliot Feb 11 '10 at 6:48
add comment

5 Answers 5

Please change the /usr/share/gnome-shell/theme/gnome-shell.css accordingly. For example, if you want to change panel font, you can add font-family: "FontName" into .panel-button. And you can further customize the font of the Dashboard, etc.

You can checkout my blog post on customizing gnome-shell: http://joneslee85.wordpress.com/2010/02/28/howto-customize-gnome-shell-theme/

share|improve this answer
add comment

Yes, it is possible. I had the same problem :) You have to edit file "/usr/share/gnome-shell/js/ui/panel.js". Find a line "const DEFAULT_FONT" and change font size (or even name). After this you have to restart gnome-shell: press Alt+F2, type "r" (without quotation marks), and press Enter.

BTW: You can customize almost everything by editing JavaScript files located in the "ui" directory.

share|improve this answer
add comment

Found this:

cd /usr/share/gnome-shell/theme
sudo gedit gnome-shell.css

I've played around with some of the settings in the gnome-shell.css file and through a bit of trial and error, managed to increase the size of the text underneath the Application icons. On line 638, I increased font-size from 7.5pt to 11.5pt which made it more readable. Code:

.app-well-app > .overview-icon,
.remove-favorite > .overview-icon,
.search-result-content > .overview-icon {
    border-radius: 4px;
    padding: 3px;
    border: 1px rgba(0,0,0,0);
    font-size: 7.5pt;
    color: white;
    transition-duration: 100;
    text-align: center;
}

I also decided to decrease the size of the icons.

.icon-grid .overview-icon {
    icon-size: 96px;
}
share|improve this answer
add comment

The posts recommending editing /usr/share/gnome-shell/theme/gnome-shell.css are correct; however, it should be noted that if you are using an alternate gnome-shell theme (e.g. you are running Linux Mint), there may be additional editable files.

For example, Mint12's 'Mint-Z' theme has configurable .css files in /usr/share/themes/Mint-Z.

Additionally, gnome-shell extensions may have their own configurable .css files, located in /usr/share/gnome-shell/extensions/{extension id}/ or $HOME/.local/share/gnome-shell/extensions/{extension id}/. I am not sure though if these settings can override theme defaults.

EDIT: @Guilherme actually answers your question.

FYI On my system (gnome-shell 3.2.1-0ubuntu1), the appropriate css selector is located in /usr/share/gnome-shell/theme/gnome-shell.css, at line 720, and is set to 7.5pt. The actual setting for my Mint12 system, however, is in /usr/share/themes/Mint-Z/gnome-shell.css, @line 880, and is set to 8pt. Modify this value, then reload your theme using the 'rt' command at the ALT+F2 prompt.

share|improve this answer
add comment
sudo gedit /usr/share/vte/termcap/xterm

Edit this line:

:co#80:it#8:li#24:\

Source:

http://ubuntuforums.org/showthread.php?t=15471

share|improve this answer
3  
The question is about the graphical "GNOME Shell", not the terminal emulator. (Also, do not edit system-wide terminfo, it will be overriden by updates. Use infocmp xterm > xterm.ti and tic xterm.ti.) –  grawity Mar 11 '11 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.