Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I discovered today that having AMD Cool n Quiet enabled in my BIOS appears to be slowing down my Windows XP SP2 system by about 29% on memory & CPU intensive workloads.

I was wondering if (a) anyone else had encountered this, (b) anyone can offer an explanation, (c) there are any negatives I need to be aware of if I keep AMD CnQ disabled.

With some superficial testing so far, I don't immediately notice any difference with CnQ off (other than the performance being what I expected from this new hardware). It seems to ramp up the CPU fan a little bit as my program maxes out 1 core, but that's the same as with CnQ on. And when I let the system idle the CPU fan slows down and the system's as quiet as a mouse (after years of 6 small fans churning like they want to go into orbit it's nice to again have a system where I can hear the HDDs seeking).

Bonus question: Does CnQ cause issues with system stability? I ask because the reason I disabled it was because I have had a few freezes and 1 spontaneous reboot with my new hardware.

share|improve this question
1  
How did you measure that 29% and what is your OS? –  Ivo Flipse Feb 11 '10 at 8:10
    
@Ivo: I have some pattern matching code written in Java which I have benchmarked across about 2 million iterations on various hardware platforms over the last 3 years. It serves as a very useful performance metric since it's been stable for about 2 years. –  Lawrence Dol Feb 11 '10 at 8:26
    
@Ivo: I added the system to the question. –  Lawrence Dol Feb 11 '10 at 8:28
1  
More precisely, what are these 29% of "slowing down"? 29% more time to execute a task? Taking more resources? –  Gnoupi Feb 11 '10 at 9:07
1  
@Gnoupi: With CnQ on a 10 second test run (after a 10 second warmup for the JVM) will total about 2 million pattern matches; with it off it will make 2.8 million. 2/2.8 = 0.71, meaning the system is 29% slower with CnQ on. Conversely 2.8/2 = 1.4, so the system is 40% faster with CnQ turned off. –  Lawrence Dol Feb 11 '10 at 20:03

3 Answers 3

http://support.microsoft.com/kb/896256

Check the PerfEnablePackageIdle registry setting. On dual core systems (e.g. my Athlon64 X2 4000+) this should have value 1.

I don't know which processor drivers or Windows updates control this setting, but i've seen systems with value 0 which will jump CPU frequency while executing a 100% single threaded task (e.g. SuperPI).

So with value 0 you won't get maximum performance with Cool n Quiet on.

share|improve this answer
up vote 3 down vote accepted

After some fairly extensive testing I have concluded that CnQ definitely does significantly negatively impact the performance of my system.

With CnQ enabled, I consistently get between 1.8/3 and 2.2/3 of the performance against when it is disabled. This is for CPU & Memory intensive code, either single or multi-threaded, although the impact is greatest when there is a single thread maxed out.

The other point is that the performance I do get varies far more with CnQ enabled. With it disabled I get very consistent numbers.


EDIT 2010-05-24: After a driver update from AMD CnQ no longer has a negative performance impact. But it still seems to cause system instability, although not as frequently as previously - every few days instead of consistently within 24 hours. A manual crash-dump generated when the system stopped responding revealed all CPU cores to be executing within the AMD CPU driver, so no real luck there except to implicate CnQ without definite proof.


EDIT 2011-02-11: After upgrading from Win XP to Win 7 the identical hardware is no longer having stability problems with CnQ and all power management functions seem to be working exactly as expected. Esp. hybrid sleep and resume are significantly improved; I love having a 3 second resume for a desktop from S3 sleep, with the disk image recorded in case of abrupt power loss.

share|improve this answer
    
I have never had any stability problems with CnQ, so it's likely that the cause of yours is something completely unrelated. –  Sasha Chedygov Aug 25 '10 at 9:52
    
@musicfreak: I was able to prove it was CnQ from both dump evidence (consistently implicating the CPU driver) and anecdotally from multiple tests enabling and disabling it, with repeatable behavior in each case. –  Lawrence Dol Feb 12 '11 at 6:40

It really don't slow down your PC . Why ?

  1. Run CPUZ
  2. Don't run anything on your computer , you'll see your CPU clock drop down .
  3. Run SuperPI or SP2004 which max your CPU usage, and your CPU clock will be at max.

CnQ really saves a lot of electricity :) But it seems like you try to over-clock your PC right ? Turn it off for more stable reason :)

share|improve this answer
    
So, you're saying it reduces power use, but might cause instability? I'll take stability over power savings any day. –  Lawrence Dol Feb 11 '10 at 8:36
    
@Software - no, he said that you might be using overclocking from your description, and you should turn that off if true, because overclocking can put pc in unstable shape. CnQ won't, however (not that I know of, at least). –  Gnoupi Feb 11 '10 at 8:38
    
@Gnoupi: Ahh. No I intend to overclock and fine tune memory settings, but only after I have established a stable baseline. So for now everything is at BIOS defaults. –  Lawrence Dol Feb 11 '10 at 8:48
    
@Software : Exactly like Gnoupi said :) If you intend to run default, you should turn on CnQ :) –  nXqd Feb 11 '10 at 9:42
1  
@nXqd: That's the point of this question, with CnQ on my system is 29% slower. –  Lawrence Dol Feb 12 '10 at 6:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.