Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Ubuntu and GNOME Do and have some bad shortcuts (they even have a grey X icon ) that I can't figure out and delete from the list.

I thought GNOME Do has some cache but its been a while and they are still there.

I deleted the ~/local/share/gnome-do folder and still no success.

Any ideas how to clear them from the list?

share|improve this question

5 Answers 5

up vote 6 down vote accepted

Maybe you have created shortcuts by some menu/shortcut editor, in my case is alacarte. I found that when I remove shortcuts from menu by alacarte, it does not remove .desktop file in ~/.local/share/applications/ but only set flag hidden=True which gnome-do somehow does not recognize this so it still display that shortcut. So make sure that .desktop file was deleted along with removing ~/.local/share/gnome-do/ directory

share|improve this answer

Removing the ~/.local/share/gnome-do/ directory worked for me, but you have to make sure you terminate gnome-do before doing so...

share|improve this answer

Probably it's a little bit a brute-force way to do it, but removing (renaming) the


folder worked for me.

share|improve this answer
didnt work for me :( – solomongaby Jul 22 '10 at 7:18

I do not use personally gnome-do, but I found How to clear the icon cache? which says:

When you change desktop files (depending on how you do it) for some reason, GNOME decides to keep copy of the old one around but just hide it. Do sees both the old and new copies. Delete the old ones and you should be good to go.

Culprit for me turned out to be in: ~/.gnome2/panel2.d/default/launchers

share|improve this answer
empty folder. tnx for the try – solomongaby Jul 23 '10 at 9:26
@solomongaby: What happens if you search for the old icons ? (I don't have DO or Gnome so can't do it.) – harrymc Jul 23 '10 at 9:58
@solomongaby: Funny question - have you checked for hidden files in the above folder? – harrymc Jul 23 '10 at 12:56
yes i did .. nothing in there – solomongaby Jul 26 '10 at 9:43
@solomongaby: Try to see if some hidden dir/file exists in $HOME. – harrymc Jul 26 '10 at 10:51

Open ~/.local/share/applications/ and find files with error names (like your error). Delete them.

Restart gnome-do or the system.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.