Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 32-bit virtual machine running in a VMWare Server virtual machine. The host is Windows 7 64-bit.

When I copy files between them it is extremely slow - it will take several minutes to copy even a 1 MB file. I can upload the file to an website and then download it again almost instantaneously by comparison.

Browsing the network is quite zippy and has no problems. I have been unable to set up a HomeGroup between the computers though - the guest always times out without managing to get setup.

Any ideas on how I should go about tracking down where the problem is?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

I've been searching for this myself on the forums. And I've eventually found the solution on VMWare's KB here

Basically it tells you to disable TCP Offloading which means your host/guest traffic is actually being sent to the NIC when all you need is for it to stay local.

My NIC driver under device manager also had additional Offload options such as checksum offloading.. I've disabled these too...

My file xfer speed between Host to Guest has now gone from 30kb/s to 50MB/s ... much better! :) Just posting it here for the benefit of future googlers...

p.s. in my case, the new settings took effect without a reboot... the NIC reset itself after changes to the driver, I've also done an ipconfig /renew on the guest.. neither host nor guest were down for this.

cheers

keywords: slow vmware server network traffic copy file guest host tcp ip LAN SMB UNC shared folders

share|improve this answer
    
Thank you very much! –  garethm Mar 16 '10 at 11:25
    
This question and answer was driving me crazy since a week now. Thank you very much! :D –  FlyBy Jan 16 '13 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.