Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This used to work perfectly up until about a month or two ago. When doing a screen capture onto the clipboard (cmd + ctr + shift + 4) and pasting it into a new document in Photoshop (only in photoshop, pasting it elsewhere like mail works fine), the drop shadow around the application doesn't look right. What can i do to fix this?

Pasting into photoshop from clipboard.

share|improve this question
    
In case this helps: It looks like the alpha channel of the image is getting discarded. The drop shadow should be partly-transparent black and you're getting opaque black instead, but in the proper area. –  Kevin Reid Feb 28 '11 at 17:38
add comment

2 Answers

You may try for these cases cmd + shift + c .It's actually a "copy merged" . It simply copies all what is visible, from all visible layers, and paste it as you are seeing it in a new Photoshop document. Or as new layer in the same one.

This way is pretty good for, even being in the layer or not with the effect, you copy the visible result of all layers. For a screen like this, you can hide the white background and then do the cmd shift c. Or hide any other, etc.

( Pasted as new layer is also good for extra effects applied over a total result, not needing a duplicate of all layers, merge, apply effect. Somewhat faster the way am telling here. )

share|improve this answer
add comment

I was getting annoyed by this too. I couldn't find a solution to this but instead i found a little workaround.

You can disable the drop shadow by typing:

defaults write com.apple.screencapture disable-shadow -bool true

in your terminal. Then you need log out and in again.

To enable the dropshadow again type:

defaults delete com.apple.screencapture disable-shadow

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.