Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've edited /etc/default/grub to set a timeout and a default selection. I ran update-grub and my changes were reflected in /boot/grub/grub.cfg. When I reboot, I can see the new default selection be highlighted for a fraction of a second, but it quickly flashes away and the first entry is highlighted instead. It's almost like it reads the configuration file but aborts and reverts to the default. Even if I set a timeout, it never times out.

I am using a very basic boot setup. I started with a brand new laptop with Windows 7 installed. I loaded Ubuntu 9.10 onto it using the install CD. GRUB 2 overwrote the Windows bootloader, like it normally does.

The only reason I can guess why this is happening is that GRUB can't or isn't reading /boot/grub/grub.cfg when it is run. It could also be that I'm editing the configuration file wrong or leaving out a step. Any suggestions?

Here is an example of a configuration I've tried:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=4
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=4
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"

sudo fdisk -l:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7c293560

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           5       40131   de  Dell Utility
/dev/sda2   *           6        1918    15360000    7  HPFS/NTFS
/dev/sda3            1918       47745   368109099    7  HPFS/NTFS
/dev/sda4           47746       60801   104872320    5  Extended
/dev/sda5           47746       60265   100566868+  83  Linux
/dev/sda6           60266       60801     4305388+  82  Linux swap / Solaris
share|improve this question
    
Could I see the output of sudo fdisk -l? –  Bobby Feb 11 '10 at 20:16
    
Just posted above –  Cory Walker Feb 11 '10 at 20:20
    
what is the default entry you're trying to boot? the win partition on /dev/sda2? –  quack quixote Feb 11 '10 at 20:46
    
Eventually I want to automatically boot Win7, but right now I'm just trying to set a default. The default I specify gets selected for a fraction of a second but disappears. –  Cory Walker Feb 11 '10 at 21:02
    
are you still having trouble? could you post your whole /boot/grub/grub.cfg (maybe to pastebin.ca )? –  quack quixote Feb 22 '10 at 23:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.