Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just changed ISP recently to 20/20 mbit and bought a Linksys WRT610N router to hook up my laptops wireless.

Everything is up and running now and I tested that the speed was as promised. Now, my first laptop runs smoothly, but my second laptop is dropping from 54mbps to 1mbps after about 5 - 10 minutes of regular surfing.

I've tried the following:

  • Change the channel (tried all of them) on the router
  • Cloning the MAC addresses on both laptops
  • DHCP reserved the IP addresses for both laptops
  • Changing security from WPA-2 to WPA
  • I'm not the most experienced when it comes to setting up network, so please bear with me ;)

    Any input on this problem will be greatly appreciated!

    Thanks in advance,

    Bo

    share|improve this question

    migrated from stackoverflow.com Feb 11 '10 at 23:53

    This question came from our site for professional and enthusiast programmers.

    add comment

    1 Answer 1

    It might be worth checking that you have the latest drivers for that laptop's wireless adaptor. It could be a bug in the firmware that causes it not to be able to retrain up to a higher speed after it has dipped down due to temporary interference, which updated drivers/firmware may resolve.

    share|improve this answer
    add comment

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.